summaryrefslogtreecommitdiff
path: root/cleopatre/buildroot/package/p1905_managerd
diff options
context:
space:
mode:
authorsamuel.chou2013-10-03 10:48:50 +0800
committersamuel.chou2013-10-11 09:33:12 +0800
commitef5c0c79316f864a38feee254c14a07fe409734c (patch)
treec8ba5986fc43ea5c2286d595edca23bef8e37464 /cleopatre/buildroot/package/p1905_managerd
parentb413722410e6da5d2600688248e9a9bca91b352c (diff)
cleo/{linux/net/bridge,devkit/p1905}: add ieee1905.1 feature, closes #4220
Diffstat (limited to 'cleopatre/buildroot/package/p1905_managerd')
-rw-r--r--cleopatre/buildroot/package/p1905_managerd/Config.in6
-rwxr-xr-xcleopatre/buildroot/package/p1905_managerd/p1905_managerd.mk77
2 files changed, 83 insertions, 0 deletions
diff --git a/cleopatre/buildroot/package/p1905_managerd/Config.in b/cleopatre/buildroot/package/p1905_managerd/Config.in
new file mode 100644
index 0000000000..2b26c45a3f
--- /dev/null
+++ b/cleopatre/buildroot/package/p1905_managerd/Config.in
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_P1905_MANAGERD
+ bool "p1905_managerd"
+ help
+ ieee1905.1 manager daemon.
+
+ http://www.spidcom.com
diff --git a/cleopatre/buildroot/package/p1905_managerd/p1905_managerd.mk b/cleopatre/buildroot/package/p1905_managerd/p1905_managerd.mk
new file mode 100755
index 0000000000..7e3e03c1a7
--- /dev/null
+++ b/cleopatre/buildroot/package/p1905_managerd/p1905_managerd.mk
@@ -0,0 +1,77 @@
+#############################################################
+#
+# p1905_managerd (provides IEEE P1905.1 functionality)
+#
+#
+#############################################################
+# Copyright (C) 2013 MStar Semiconductor, Inc.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU Library General Public License as
+# published by the Free Software Foundation; either version 2 of the
+# License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Library General Public License for more details.
+#
+# You should have received a copy of the GNU Library General Public
+# License along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+# USA
+#
+
+BUILDROOT_CONFIG_FILE:=$(BASE_DIR)/.config
+
+P1905_MANAGERD_VERSION:=0.0.1
+P1905_MANAGERD_SITE:=$(BASE_DIR)/../devkit/p1905_managerd
+P1905_MANAGERD_NAME:=p1905_managerd-$(P1905_MANAGERD_VERSION)
+P1905_MANAGERD_DIR:=$(BUILD_DIR)/p1905_managerd-$(P1905_MANAGERD_VERSION)
+
+p1905_managerd-source:
+
+$(P1905_MANAGERD_DIR)/.unpacked:
+ echo "$(P1905_MANAGERD_DIR)"
+ ln -s $(P1905_MANAGERD_SITE) $(P1905_MANAGERD_DIR)
+ touch $(P1905_MANAGERD_DIR)/.unpacked
+
+$(P1905_MANAGERD_DIR)/.configured: $(P1905_MANAGERD_DIR)/.unpacked $(BUILDROOT_CONFIG_FILE)
+ touch $(P1905_MANAGERD_DIR)/.configured
+
+$(P1905_MANAGERD_DIR)/p1905_managerd: $(P1905_MANAGERD_DIR)/.configured
+ (cd $(P1905_MANAGERD_DIR); \
+ $(TARGET_CONFIGURE_OPTS) $(MAKE) LINUX_DIR="$(BASE_DIR)/../linux-2.6.25.10-spc300" \
+ LIBMME_DIR="$(BASE_DIR)/../application/libmme" \
+ LIBSPID_DIR="$(BASE_DIR)/../application/libspid" \
+ LIBALME_DIR="$(BASE_DIR)/../application/libalme")
+
+$(TARGET_DIR)/usr/sbin/p1905_managerd: $(P1905_MANAGERD_DIR)/p1905_managerd
+ mkdir -p $(TARGET_DIR)/usr/sbin
+ cp $< $@
+
+$(TARGET_DIR)/etc/init.d/S98p1905: $(P1905_MANAGERD_DIR)/S98p1905
+ mkdir -p $(TARGET_DIR)/etc/init.d
+ cp $< $@
+ chmod a+x $@
+
+p1905_managerd: uclibc $(TARGET_DIR)/usr/sbin/p1905_managerd $(TARGET_DIR)/etc/init.d/S98p1905
+
+p1905_managerd-clean:
+ rm -f $(TARGET_DIR)/usr/sbin/p1905_managerd
+ -$(MAKE) -C $(P1905_MANAGERD_DIR) clean
+
+p1905_managerd-dirclean:
+ rm -f $(P1905_MANAGERD_DIR)
+
+# We declare $(P1905_MANAGERD_DIR)/p1905_managerd rule as PHONY to force compilation
+.PHONY: $(P1905_MANAGERD_DIR)/p1905_managerd
+
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(strip $(BR2_PACKAGE_P1905_MANAGERD)),y)
+TARGETS+=p1905_managerd
+endif