summaryrefslogtreecommitdiff
path: root/cleopatre/buildroot
diff options
context:
space:
mode:
authorsamuel.chou2013-10-03 10:48:50 +0800
committersamuel.chou2013-10-11 09:33:12 +0800
commitef5c0c79316f864a38feee254c14a07fe409734c (patch)
treec8ba5986fc43ea5c2286d595edca23bef8e37464 /cleopatre/buildroot
parentb413722410e6da5d2600688248e9a9bca91b352c (diff)
cleo/{linux/net/bridge,devkit/p1905}: add ieee1905.1 feature, closes #4220
Diffstat (limited to 'cleopatre/buildroot')
-rw-r--r--cleopatre/buildroot/package/Config.in6
-rw-r--r--cleopatre/buildroot/package/libalme/Config.in6
-rw-r--r--cleopatre/buildroot/package/libalme/libalme.mk73
-rw-r--r--cleopatre/buildroot/package/p1905_managerd/Config.in6
-rwxr-xr-xcleopatre/buildroot/package/p1905_managerd/p1905_managerd.mk77
-rw-r--r--cleopatre/buildroot/target/device/Spidcom/common/defconfig.base2
-rw-r--r--cleopatre/buildroot/target/device/Spidcom/common/linux26.config.base1
-rw-r--r--cleopatre/buildroot/target/device/Spidcom/targets/mpr520e/defconfig.part5
-rw-r--r--cleopatre/buildroot/target/device/Spidcom/targets/mpr520e/linux26.config.part1
9 files changed, 176 insertions, 1 deletions
diff --git a/cleopatre/buildroot/package/Config.in b/cleopatre/buildroot/package/Config.in
index 7eaca7887b..63fbb75994 100644
--- a/cleopatre/buildroot/package/Config.in
+++ b/cleopatre/buildroot/package/Config.in
@@ -106,6 +106,9 @@ source "package/module-init-tools/Config.in"
source "package/modutils/Config.in"
endif
source "package/ng-spice-rework/Config.in"
+if BR2_TARGET_SPIDCOM
+source "package/p1905_managerd/Config.in"
+endif
source "package/popt/Config.in"
source "package/portage/Config.in"
if !BR2_PACKAGE_BUSYBOX_HIDE_OTHERS
@@ -184,6 +187,9 @@ source "package/ipsec-tools/Config.in"
source "package/iptables/Config.in"
source "package/kismet/Config.in"
source "package/l2tp/Config.in"
+if BR2_TARGET_SPIDCOM
+source "package/libalme/Config.in"
+endif
source "package/libcgi/Config.in"
source "package/libcgicc/Config.in"
source "package/libeXosip2/Config.in"
diff --git a/cleopatre/buildroot/package/libalme/Config.in b/cleopatre/buildroot/package/libalme/Config.in
new file mode 100644
index 0000000000..16d8b2c702
--- /dev/null
+++ b/cleopatre/buildroot/package/libalme/Config.in
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_LIBALME
+ bool "libalme"
+ help
+ ALME library for other application use.
+
+ http://www.mstarsemi.com
diff --git a/cleopatre/buildroot/package/libalme/libalme.mk b/cleopatre/buildroot/package/libalme/libalme.mk
new file mode 100644
index 0000000000..9d5c73cf83
--- /dev/null
+++ b/cleopatre/buildroot/package/libalme/libalme.mk
@@ -0,0 +1,73 @@
+#############################################################
+#
+# libalme (provides APIs for ALME communications needed by applications)
+#
+#############################################################
+# (C) Copyright 2013 MStar Semiconductor, Inc.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU Library General Public License as
+# published by the Free Software Foundation; either version 2 of the
+# License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Library General Public License for more details.
+#
+# You should have received a copy of the GNU Library General Public
+# License along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+# USA
+#
+
+LIBALME_VERSION_MSB:=0
+LIBALME_VERSION:=$(LIBALME_VERSION_MSB).0.1
+LIBALME_SITE:=$(BASE_DIR)/../application/libalme
+LIBALME_NAME:=libalme.so.$(LIBALME_VERSION)
+LIBALME_DIR:=$(BUILD_DIR)/libalme-$(LIBALME_VERSION)
+
+LIBALME_BIN_SO := $(LIBALME_SITE)/libalme.so $(LIBALME_DIR)/libalme.so
+
+libalme-source:
+
+$(LIBALME_DIR)/.unpacked:
+ ln -s $(LIBALME_SITE) $(LIBALME_DIR)
+ touch $(LIBALME_DIR)/.unpacked
+
+$(LIBALME_DIR)/.configured: $(LIBALME_DIR)/.unpacked
+ touch $(LIBALME_DIR)/.configured
+
+$(LIBALME_BIN_SO): $(LIBALME_DIR)/.configured FORCE_LIBALME_MAKE
+ @$(TARGET_CONFIGURE_OPTS) \
+ $(MAKE) -C $(LIBALME_DIR) libalme.so
+
+$(TARGET_DIR)/usr/lib/$(LIBALME_NAME): $(LIBALME_DIR)/libalme.so
+ mkdir -p $(TARGET_DIR)/usr/lib
+ cp $< $@
+ (cd $(TARGET_DIR)/usr/lib; \
+ ln -fs $(LIBALME_NAME) libalme.so; \
+ ln -fs $(LIBALME_NAME) libalme.so.$(LIBALME_VERSION_MSB))
+
+libalme: uclibc $(TARGET_DIR)/usr/lib/$(LIBALME_NAME)
+
+libalme-clean:
+ rm -f $(TARGET_DIR)/usr/lib/libalme.so
+ rm -f $(TARGET_DIR)/usr/lib/libalme.so.$(LIBALME_VERSION_MSB)
+ rm -f $(TARGET_DIR)/usr/lib/$(LIBALME_NAME)
+ -$(MAKE) -C $(LIBALME_DIR) clean
+
+libalme-dirclean:
+ rm -f $(LIBALME_DIR)
+
+# We declare FORCE_LIBALME_MAKE rule as PHONY to force compilation
+.PHONY: FORCE_LIBALME_MAKE
+
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(strip $(BR2_PACKAGE_LIBALME)),y)
+TARGETS+=libalme
+endif
diff --git a/cleopatre/buildroot/package/p1905_managerd/Config.in b/cleopatre/buildroot/package/p1905_managerd/Config.in
new file mode 100644
index 0000000000..2b26c45a3f
--- /dev/null
+++ b/cleopatre/buildroot/package/p1905_managerd/Config.in
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_P1905_MANAGERD
+ bool "p1905_managerd"
+ help
+ ieee1905.1 manager daemon.
+
+ http://www.spidcom.com
diff --git a/cleopatre/buildroot/package/p1905_managerd/p1905_managerd.mk b/cleopatre/buildroot/package/p1905_managerd/p1905_managerd.mk
new file mode 100755
index 0000000000..7e3e03c1a7
--- /dev/null
+++ b/cleopatre/buildroot/package/p1905_managerd/p1905_managerd.mk
@@ -0,0 +1,77 @@
+#############################################################
+#
+# p1905_managerd (provides IEEE P1905.1 functionality)
+#
+#
+#############################################################
+# Copyright (C) 2013 MStar Semiconductor, Inc.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU Library General Public License as
+# published by the Free Software Foundation; either version 2 of the
+# License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Library General Public License for more details.
+#
+# You should have received a copy of the GNU Library General Public
+# License along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+# USA
+#
+
+BUILDROOT_CONFIG_FILE:=$(BASE_DIR)/.config
+
+P1905_MANAGERD_VERSION:=0.0.1
+P1905_MANAGERD_SITE:=$(BASE_DIR)/../devkit/p1905_managerd
+P1905_MANAGERD_NAME:=p1905_managerd-$(P1905_MANAGERD_VERSION)
+P1905_MANAGERD_DIR:=$(BUILD_DIR)/p1905_managerd-$(P1905_MANAGERD_VERSION)
+
+p1905_managerd-source:
+
+$(P1905_MANAGERD_DIR)/.unpacked:
+ echo "$(P1905_MANAGERD_DIR)"
+ ln -s $(P1905_MANAGERD_SITE) $(P1905_MANAGERD_DIR)
+ touch $(P1905_MANAGERD_DIR)/.unpacked
+
+$(P1905_MANAGERD_DIR)/.configured: $(P1905_MANAGERD_DIR)/.unpacked $(BUILDROOT_CONFIG_FILE)
+ touch $(P1905_MANAGERD_DIR)/.configured
+
+$(P1905_MANAGERD_DIR)/p1905_managerd: $(P1905_MANAGERD_DIR)/.configured
+ (cd $(P1905_MANAGERD_DIR); \
+ $(TARGET_CONFIGURE_OPTS) $(MAKE) LINUX_DIR="$(BASE_DIR)/../linux-2.6.25.10-spc300" \
+ LIBMME_DIR="$(BASE_DIR)/../application/libmme" \
+ LIBSPID_DIR="$(BASE_DIR)/../application/libspid" \
+ LIBALME_DIR="$(BASE_DIR)/../application/libalme")
+
+$(TARGET_DIR)/usr/sbin/p1905_managerd: $(P1905_MANAGERD_DIR)/p1905_managerd
+ mkdir -p $(TARGET_DIR)/usr/sbin
+ cp $< $@
+
+$(TARGET_DIR)/etc/init.d/S98p1905: $(P1905_MANAGERD_DIR)/S98p1905
+ mkdir -p $(TARGET_DIR)/etc/init.d
+ cp $< $@
+ chmod a+x $@
+
+p1905_managerd: uclibc $(TARGET_DIR)/usr/sbin/p1905_managerd $(TARGET_DIR)/etc/init.d/S98p1905
+
+p1905_managerd-clean:
+ rm -f $(TARGET_DIR)/usr/sbin/p1905_managerd
+ -$(MAKE) -C $(P1905_MANAGERD_DIR) clean
+
+p1905_managerd-dirclean:
+ rm -f $(P1905_MANAGERD_DIR)
+
+# We declare $(P1905_MANAGERD_DIR)/p1905_managerd rule as PHONY to force compilation
+.PHONY: $(P1905_MANAGERD_DIR)/p1905_managerd
+
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(strip $(BR2_PACKAGE_P1905_MANAGERD)),y)
+TARGETS+=p1905_managerd
+endif
diff --git a/cleopatre/buildroot/target/device/Spidcom/common/defconfig.base b/cleopatre/buildroot/target/device/Spidcom/common/defconfig.base
index 95dd8b8402..c47396d6b3 100644
--- a/cleopatre/buildroot/target/device/Spidcom/common/defconfig.base
+++ b/cleopatre/buildroot/target/device/Spidcom/common/defconfig.base
@@ -249,6 +249,7 @@ BR2_PACKAGE_FW_WD=y
# BR2_PACKAGE_IPKG is not set
# BR2_PACKAGE_KEXEC is not set
# BR2_PACKAGE_LESS is not set
+# BR2_PACKAGE_LIBALME is not set
# BR2_PACKAGE_LIBDAEMON is not set
# BR2_PACKAGE_LIBELF is not set
# BR2_PACKAGE_LIBEVENT is not set
@@ -267,6 +268,7 @@ BR2_PACKAGE_MANAGERD=y
# BR2_PACKAGE_MODULE_INIT_TOOLS is not set
# BR2_PACKAGE_MODUTILS is not set
# BR2_PACKAGE_NG_SPICE_REWORK is not set
+# BR2_PACKAGE_P1905_MANAGERD is not set
# BR2_PACKAGE_POPT is not set
# BR2_PACKAGE_PORTAGE is not set
# BR2_PACKAGE_PROCPS is not set
diff --git a/cleopatre/buildroot/target/device/Spidcom/common/linux26.config.base b/cleopatre/buildroot/target/device/Spidcom/common/linux26.config.base
index 62c578b2ee..7149448fc3 100644
--- a/cleopatre/buildroot/target/device/Spidcom/common/linux26.config.base
+++ b/cleopatre/buildroot/target/device/Spidcom/common/linux26.config.base
@@ -255,6 +255,7 @@ CONFIG_VLAN_8021Q=y
# CONFIG_ECONET is not set
# CONFIG_WAN_ROUTER is not set
# CONFIG_NET_SCHED is not set
+# CONFIG_IEEE1905_1_FORWARD_ENTITY is not set
#
# Network testing
diff --git a/cleopatre/buildroot/target/device/Spidcom/targets/mpr520e/defconfig.part b/cleopatre/buildroot/target/device/Spidcom/targets/mpr520e/defconfig.part
index 29c6cdccf9..2773e0133b 100644
--- a/cleopatre/buildroot/target/device/Spidcom/targets/mpr520e/defconfig.part
+++ b/cleopatre/buildroot/target/device/Spidcom/targets/mpr520e/defconfig.part
@@ -3,4 +3,7 @@ BR2_HOSTNAME="mpr520e"
BR2_TARGET_SPIDCOM_MPR520E=y
BR2_PACKAGE_PMD=y
BR2_PACKAGE_MT7601UDRV=y
-BR2_PACKAGE_SPIDGOAHEAD=y \ No newline at end of file
+BR2_PACKAGE_SPIDGOAHEAD=y
+BR2_PACKAGE_P1905_MANAGERD=y
+BR2_PACKAGE_LIBALME=y
+
diff --git a/cleopatre/buildroot/target/device/Spidcom/targets/mpr520e/linux26.config.part b/cleopatre/buildroot/target/device/Spidcom/targets/mpr520e/linux26.config.part
index 18bae9f1dc..3d9cf8eed6 100644
--- a/cleopatre/buildroot/target/device/Spidcom/targets/mpr520e/linux26.config.part
+++ b/cleopatre/buildroot/target/device/Spidcom/targets/mpr520e/linux26.config.part
@@ -17,6 +17,7 @@ CONFIG_SUSPEND_FREEZER=y
CONFIG_REALTEK_PHY=y
CONFIG_NETDEV_1000=y
+CONFIG_IEEE1905_1_FORWARD_ENTITY=y
#
# Kernel Features