summaryrefslogtreecommitdiff
path: root/i/simulotron/src/Makefile.am
diff options
context:
space:
mode:
authorhaller2005-11-29 01:58:16 +0000
committerhaller2005-11-29 01:58:16 +0000
commit8020ef753b8d434c026299650fe911d71d844e78 (patch)
treec8ba23fd3d95cbd12067d2437d678f50c196442b /i/simulotron/src/Makefile.am
parent1c63701ecc8a1cff6979bdb3688cf62f4cc267f5 (diff)
Modification dans l'A/A
Codage du test de socket(qui foire)
Diffstat (limited to 'i/simulotron/src/Makefile.am')
-rw-r--r--i/simulotron/src/Makefile.am16
1 files changed, 8 insertions, 8 deletions
diff --git a/i/simulotron/src/Makefile.am b/i/simulotron/src/Makefile.am
index 3a767e2..5695d4d 100644
--- a/i/simulotron/src/Makefile.am
+++ b/i/simulotron/src/Makefile.am
@@ -1,14 +1,14 @@
-SUBDIRS = utils socket
+check_PROGRAMS =
+
+include socket/Makefile.incl.am
+include utils/Makefile.incl.am
bin_PROGRAMS = simulotron
simulotron_SOURCES = main.cc \
- socket/address.hh socket/address.cc \
- socket/socket.cc socket/socket.hh \
- utils/errno_exception.hh
+ $(socket_S)
-simulotron_CXXFLAGS = -g -Wall -fmessage-length=0
+AM_CXXFLAGS = -g -Wall -fmessage-length=0
simulotron_LDADD =
-INCLUDES = -I../../src
+INCLUDES = -I$(srcdir)
-TESTS = socket/test_socket \
- utils/test_errno_exception
+TESTS = $(check_PROGRAMS)