summaryrefslogtreecommitdiff
path: root/i/simulotron/src/Makefile.am
diff options
context:
space:
mode:
authorhaller2005-11-28 16:24:57 +0000
committerhaller2005-11-28 16:24:57 +0000
commit1c63701ecc8a1cff6979bdb3688cf62f4cc267f5 (patch)
tree4b2abf71fea63309c7a3d9d00def0aaa557b2462 /i/simulotron/src/Makefile.am
parent87e2e08ed7b47f30e458736dbfbb1ede75349d40 (diff)
Quelques modifs dans l'A/A
* Rapatriement des test dans src * Ajout d'un test pipo pour errno_exception
Diffstat (limited to 'i/simulotron/src/Makefile.am')
-rw-r--r--i/simulotron/src/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/i/simulotron/src/Makefile.am b/i/simulotron/src/Makefile.am
index 7302a68..3a767e2 100644
--- a/i/simulotron/src/Makefile.am
+++ b/i/simulotron/src/Makefile.am
@@ -1,9 +1,14 @@
+SUBDIRS = utils socket
+
bin_PROGRAMS = simulotron
simulotron_SOURCES = main.cc \
- socket/socket.cc socket/socket.hh \
- socket/address.cc socket/address.hh \
+ socket/address.hh socket/address.cc \
+ socket/socket.cc socket/socket.hh \
utils/errno_exception.hh
simulotron_CXXFLAGS = -g -Wall -fmessage-length=0
simulotron_LDADD =
INCLUDES = -I../../src
+
+TESTS = socket/test_socket \
+ utils/test_errno_exception