summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJoey Hess2014-04-03 00:59:26 -0400
committerJoey Hess2014-04-03 01:55:49 -0400
commit42f207232beb57c18f67884e7c28424dba3c84c6 (patch)
treefe389f774e2f0de6cd5562b9b349f727319cc03f /debian
parent167609746d22951477abd6490b34480205c659af (diff)
debianization and a wrapper program for /usr/bin
Diffstat (limited to 'debian')
-rw-r--r--debian/README.Debian (renamed from debian/README)0
-rw-r--r--debian/changelog8
-rw-r--r--debian/compat1
-rw-r--r--debian/control36
-rw-r--r--debian/copyright11
-rw-r--r--debian/lintian-overrides3
-rw-r--r--debian/propellor.115
-rwxr-xr-xdebian/rules14
8 files changed, 87 insertions, 1 deletions
diff --git a/debian/README b/debian/README.Debian
index e32a0ee3..e32a0ee3 100644
--- a/debian/README
+++ b/debian/README.Debian
diff --git a/debian/changelog b/debian/changelog
index 73ace3dd..09d8492d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,4 +1,10 @@
-propellor (0.2) unstable; urgency=low
+propellor (0.2.1) unstable; urgency=medium
+
+ * First release with Debian package.
+
+ -- Joey Hess <joeyh@debian.org> Thu, 03 Apr 2014 01:43:14 -0400
+
+propellor (0.2.0) unstable; urgency=low
* Added support for provisioning Docker containers.
* Bootstrap deployment now pushes the git repo to the remote host
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 00000000..ec635144
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+9
diff --git a/debian/control b/debian/control
new file mode 100644
index 00000000..3f5cb2da
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,36 @@
+Source: propellor
+Section: admin
+Priority: optional
+Build-Depends:
+ debhelper (>= 9),
+ ghc (>= 7.4),
+ cabal-install,
+ libghc-async-dev,
+ libghc-missingh-dev,
+ libghc-hslogger-dev,
+ libghc-unix-compat-dev,
+ libghc-ansi-terminal-dev,
+ libghc-ifelse-dev,
+Maintainer: Joey Hess <joeyh@debian.org>
+Standards-Version: 3.9.5
+Vcs-Git: git://git.kitenet.net/propellor
+Homepage: http://joeyh.name/code/propellor/
+
+Package: propellor
+Architecture: any
+Section: admin
+Depends: ${misc:Depends}, ${shlibs:Depends},
+ ghc (>= 7.4),
+ cabal-install,
+ libghc-async-dev,
+ libghc-missingh-dev,
+ libghc-hslogger-dev,
+ libghc-unix-compat-dev,
+ libghc-ansi-terminal-dev,
+ libghc-ifelse-dev,
+ git,
+Description: property-based host configuration management in haskell
+ Propellor enures that the system it's run in satisfies a list of
+ properties, taking action as necessary when a property is not yet met.
+ .
+ It is configured using haskell.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 00000000..690a9af8
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,11 @@
+Format: http://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Source: native package
+
+Files: *
+Copyright: © 2010-2014 Joey Hess <joey@kitenet.net>
+License: GPL-3+
+
+License: GPL-3+
+ The full text of version 3 of the GPL is distributed as GPL in
+ this package's source, or in /usr/share/common-licenses/GPL-3 on
+ Debian systems.
diff --git a/debian/lintian-overrides b/debian/lintian-overrides
new file mode 100644
index 00000000..9071fe0f
--- /dev/null
+++ b/debian/lintian-overrides
@@ -0,0 +1,3 @@
+# These files are used in a git repository that propellor sets up.
+propellor: package-contains-vcs-control-file usr/src/propellor/.gitignore
+propellor: extra-license-file usr/src/propellor/GPL
diff --git a/debian/propellor.1 b/debian/propellor.1
new file mode 100644
index 00000000..3ee3bf4a
--- /dev/null
+++ b/debian/propellor.1
@@ -0,0 +1,15 @@
+.\" -*- nroff -*-
+.TH propellor 1 "Commands"
+.SH NAME
+propellor \- property-based host configuration management in haskell
+.SH SYNOPSIS
+.B propellor [options] host
+.SH DESCRIPTION
+.I propellor
+is a property-based host configuration management program written
+and configured in haskell.
+.PP
+The first time you run propellor, it will set up a ~/.propellor/
+repository. Edit ~/.propellor/config.hs to configure it.
+.SH AUTHOR
+Joey Hess <joey@kitenet.net>
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 00000000..dafe10f6
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,14 @@
+#!/usr/bin/make -f
+
+# Avoid using cabal, as it writes to $HOME
+export CABAL=./Setup
+
+%:
+ dh $@
+
+override_dh_auto_build:
+ $(MAKE) build
+override_dh_installdocs:
+ dh_installdocs README.md TODO
+override_dh_installman:
+ dh_installman debian/propellor.1