summaryrefslogtreecommitdiff
path: root/polux/package/initramfs/initramfs.mk
diff options
context:
space:
mode:
Diffstat (limited to 'polux/package/initramfs/initramfs.mk')
-rw-r--r--polux/package/initramfs/initramfs.mk8
1 files changed, 6 insertions, 2 deletions
diff --git a/polux/package/initramfs/initramfs.mk b/polux/package/initramfs/initramfs.mk
index dc19465cb7..8a26cfb481 100644
--- a/polux/package/initramfs/initramfs.mk
+++ b/polux/package/initramfs/initramfs.mk
@@ -9,10 +9,14 @@ TARGET_MDIR=$(TARGET_DIR)/lib/modules/
-include $(LINUX_DIR)/.config
# Create suffixes
-ifeq ($(CONFIG_ARCH_SPC200C),y)
+ifeq ($(BR2_CONFIG_MARCH_MSE500),y)
+PLATFORM=mse500
+else ifeq ($(BR2_CONFIG_MARCH_SPC200C),y)
PLATFORM=spc200c
-else
+else ifeq ($(BR2_CONFIG_MARCH_SPC200E),y)
PLATFORM=spc200e
+else
+$(error unknown architecture)
endif
ifeq ($(BR2_CONFIG_SLAVE),y)