summaryrefslogtreecommitdiff
path: root/cleopatre/buildroot/package/ltp-testsuite
diff options
context:
space:
mode:
Diffstat (limited to 'cleopatre/buildroot/package/ltp-testsuite')
-rw-r--r--cleopatre/buildroot/package/ltp-testsuite/Config.in6
-rw-r--r--cleopatre/buildroot/package/ltp-testsuite/ltp-testsuite-disable-ipv6-tests.patch123
-rw-r--r--cleopatre/buildroot/package/ltp-testsuite/ltp-testsuite-enable-openposix-for-nptl.patch33
-rw-r--r--cleopatre/buildroot/package/ltp-testsuite/ltp-testsuite-generate-needs-bash.patch8
-rw-r--r--cleopatre/buildroot/package/ltp-testsuite/ltp-testsuite-sh-is-not-C-code.patch11
-rw-r--r--cleopatre/buildroot/package/ltp-testsuite/ltp-testsuite.mk69
-rw-r--r--cleopatre/buildroot/package/ltp-testsuite/ltp-testsuite.patch73
7 files changed, 323 insertions, 0 deletions
diff --git a/cleopatre/buildroot/package/ltp-testsuite/Config.in b/cleopatre/buildroot/package/ltp-testsuite/Config.in
new file mode 100644
index 0000000000..46c82214f0
--- /dev/null
+++ b/cleopatre/buildroot/package/ltp-testsuite/Config.in
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_LTP-TESTSUITE
+ bool "ltp-testsuite"
+ help
+ The Linux Test Project provides a huge testsuite for Linux.
+
+ http://ltp.sourceforge.net/
diff --git a/cleopatre/buildroot/package/ltp-testsuite/ltp-testsuite-disable-ipv6-tests.patch b/cleopatre/buildroot/package/ltp-testsuite/ltp-testsuite-disable-ipv6-tests.patch
new file mode 100644
index 0000000000..6f1a92744a
--- /dev/null
+++ b/cleopatre/buildroot/package/ltp-testsuite/ltp-testsuite-disable-ipv6-tests.patch
@@ -0,0 +1,123 @@
+diff -ur ltp-full-20070228/testcases/network/sctp/func_tests/Makefile ltp-full-20070228-patched/testcases/network/sctp/func_tests/Makefile
+--- ltp-full-20070228/testcases/network/sctp/func_tests/Makefile 2007-02-28 22:40:32.000000000 -0600
++++ ltp-full-20070228-patched/testcases/network/sctp/func_tests/Makefile 2007-07-05 22:40:08.524219814 -0500
+@@ -26,8 +26,6 @@
+
+ LOADLIBES += $(LIBS) -lltp -lsctputil -lsctp -lpthread
+
+-V6FLAGS = -DTEST_V6=1 $(CFLAGS)
+-
+ SRCS = $(wildcard *.c)
+
+ V4_TARGETS = test_1_to_1_accept_close test_1_to_1_addrs test_1_to_1_connect \
+@@ -42,11 +40,7 @@
+ test_sctp_sendrecvmsg test_sockopt test_tcp_style \
+ test_timetolive test_1_to_1_connectx test_connectx
+
+-V6_TARGETS = test_basic_v6 test_fragments_v6 test_getname_v6 \
+- test_inaddr_any_v6 test_peeloff_v6 test_sctp_sendrecvmsg_v6 \
+- test_sockopt_v6 test_tcp_style_v6 test_timetolive_v6
+-
+-all: $(V4_TARGETS) $(V6_TARGETS)
++all: $(V4_TARGETS)
+
+ test_1_to_1_accept_close: test_1_to_1_accept_close.c
+ test_1_to_1_addrs: test_1_to_1_addrs.c
+@@ -68,47 +62,19 @@
+ test_assoc_shutdown: test_assoc_shutdown.c
+ test_autoclose: test_autoclose.c
+ test_basic: test_basic.c
+-test_basic_v6: test_basic_v6.o
+ test_connect: test_connect.c
+ test_fragments: test_fragments.c
+-test_fragments_v6: test_fragments_v6.o
+ test_getname: test_getname.c
+-test_getname_v6: test_getname_v6.o
+ test_inaddr_any: test_inaddr_any.c
+-test_inaddr_any_v6: test_inaddr_any_v6.o
+ test_peeloff: test_peeloff.c
+-test_peeloff_v6: test_peeloff_v6.o
+ test_recvmsg: test_recvmsg.c
+ test_sctp_sendrecvmsg: test_sctp_sendrecvmsg.c
+-test_sctp_sendrecvmsg_v6: test_sctp_sendrecvmsg_v6.o
+ test_sockopt: test_sockopt.c
+-test_sockopt_v6: test_sockopt_v6.o
+ test_tcp_style: test_tcp_style.c
+-test_tcp_style_v6: test_tcp_style_v6.o
+ test_timetolive: test_timetolive.c
+-test_timetolive_v6: test_timetolive_v6.o
+ test_1_to_1_connectx: test_1_to_1_connectx.c
+ test_connectx: test_connectx.c
+
+-test_basic_v6.o: test_basic.c
+- $(CC) -c $(V6FLAGS) -o $@ $^
+-test_fragments_v6.o: test_fragments.c
+- $(CC) -c $(V6FLAGS) -o $@ $^
+-test_getname_v6.o: test_getname.c
+- $(CC) -c $(V6FLAGS) -o $@ $^
+-test_inaddr_any_v6.o: test_inaddr_any.c
+- $(CC) -c $(V6FLAGS) -o $@ $^
+-test_peeloff_v6.o: test_peeloff.c
+- $(CC) -c $(V6FLAGS) -o $@ $^
+-test_sctp_sendrecvmsg_v6.o: test_sctp_sendrecvmsg.c
+- $(CC) -c $(V6FLAGS) -o $@ $^
+-test_sockopt_v6.o: test_sockopt.c
+- $(CC) -c $(V6FLAGS) -o $@ $^
+-test_tcp_style_v6.o: test_tcp_style.c
+- $(CC) -c $(V6FLAGS) -o $@ $^
+-test_timetolive_v6.o: test_timetolive.c
+- $(CC) -c $(V6FLAGS) -o $@ $^
+-
+ v4test: ${V4_TARGETS}
+ @for a in $^; \
+ do \
+@@ -123,26 +89,9 @@
+ fi; \
+ done
+
+-v6test: ${V6_TARGETS}
+- @for a in $^; \
+- do \
+- echo "./$$a"; \
+- if ./$$a; \
+- then \
+- echo "$$a passes"; \
+- echo ""; \
+- else \
+- echo "$$a fails"; \
+- exit 1; \
+- fi; \
+- done
+-
+ install:
+ ln -f $(V4_TARGETS) ../../../bin
+- ln -f $(V6_TARGETS) ../../../bin
+
+ clean:
+ rm -f $(V4_TARGETS)
+- rm -f $(V6_TARGETS)
+- rm -f ../../../bin/$(V6_TARGETS)
+ rm -f *.o
+diff -ur ltp-full-20070228/testcases/network/stress/ns-tools/Makefile ltp-full-20070228-patched/testcases/network/stress/ns-tools/Makefile
+--- ltp-full-20070228/testcases/network/stress/ns-tools/Makefile 2007-02-28 22:40:31.000000000 -0600
++++ ltp-full-20070228-patched/testcases/network/stress/ns-tools/Makefile 2007-07-05 22:39:27.593059603 -0500
+@@ -10,9 +10,8 @@
+ ns-echoclient
+
+ BINS=ns-tcpserver ns-tcpclient ns-udpserver ns-udpclient \
+- ns-icmpv4_sender ns-icmpv6_sender \
++ ns-icmpv4_sender \
+ ns-udpsender \
+- ns-icmp_redirector \
+ ns-mcast_receiver ns-igmp_querier \
+ ns-mcast_join
+
+diff -ur ltp-full-20070228/tools/Makefile ltp-full-20070228-patched/tools/Makefile
+--- ltp-full-20070228/tools/Makefile 2007-02-28 22:40:41.000000000 -0600
++++ ltp-full-20070228-patched/tools/Makefile 2007-07-05 22:39:27.593059603 -0500
+@@ -1,4 +1,4 @@
+-SUBDIRS = apicmds genload netpipe-2.4 netpipe-2.4-ipv6 #top-LTP
++SUBDIRS = apicmds genload netpipe-2.4 #top-LTP
+
+ CFLAGS+= -Wall -I../include
+ LOADLIBES+= -L../lib -lltp
diff --git a/cleopatre/buildroot/package/ltp-testsuite/ltp-testsuite-enable-openposix-for-nptl.patch b/cleopatre/buildroot/package/ltp-testsuite/ltp-testsuite-enable-openposix-for-nptl.patch
new file mode 100644
index 0000000000..ebb888cd9f
--- /dev/null
+++ b/cleopatre/buildroot/package/ltp-testsuite/ltp-testsuite-enable-openposix-for-nptl.patch
@@ -0,0 +1,33 @@
+diff -ur ltp-full-20060615/testcases/Makefile ltp-full-20060615-patched/testcases/Makefile
+--- ltp-full-20060615/testcases/Makefile 2006-01-31 08:48:38.000000000 -0600
++++ ltp-full-20060615-patched/testcases/Makefile 2006-07-04 22:20:40.298850250 -0500
+@@ -1,4 +1,4 @@
+-SUBDIRS = `ls */Makefile | sed "s/Makefile//g" | grep -v open | grep -v pounder | grep -v DOTS`
++SUBDIRS = `ls */Makefile | sed "s/Makefile//g" | grep -v open_hpi | grep -v pounder | grep -v DOTS`
+ UCLINUX_SUBDIRS = kernel
+
+ all:
+diff -ur ltp-full-20060615/testcases/open_posix_testsuite/LDFLAGS ltp-full-20060615-patched/testcases/open_posix_testsuite/LDFLAGS
+--- ltp-full-20060615/testcases/open_posix_testsuite/LDFLAGS 2005-06-03 11:29:49.000000000 -0500
++++ ltp-full-20060615-patched/testcases/open_posix_testsuite/LDFLAGS 2006-07-04 22:21:34.322226500 -0500
+@@ -14,3 +14,5 @@
+ # allow for the NPTL-specific compilation (used in some test cases)
+ # Note: this sometimes require the package nptl-devel.*.rpm to be installed.
+ #-I /usr/include/nptl -L /usr/lib/nptl -D_XOPEN_SOURCE=600 -lpthread -lrt -lm
++
++-D_XOPEN_SOURCE=600 -lpthread -lrt -lm -D_GNU_SOURCE
+diff -ur ltp-full-20060615/testcases/open_posix_testsuite/Makefile ltp-full-20060615-patched/testcases/open_posix_testsuite/Makefile
+--- ltp-full-20060615/testcases/open_posix_testsuite/Makefile 2006-05-21 18:38:52.000000000 -0500
++++ ltp-full-20060615-patched/testcases/open_posix_testsuite/Makefile 2006-07-04 22:22:16.660872500 -0500
+@@ -45,7 +45,10 @@
+ TIMEOUT = $(top_builddir)/t0 $(TIMEOUT_VAL)
+
+
+-all: build-tests run-tests
++all: build-tests $(top_builddir)/t0
++
++install:
++ @echo " "
+
+ build-tests: $(BUILD_TESTS:.c=.test)
+ run-tests: $(RUN_TESTS:.test=.run-test)
diff --git a/cleopatre/buildroot/package/ltp-testsuite/ltp-testsuite-generate-needs-bash.patch b/cleopatre/buildroot/package/ltp-testsuite/ltp-testsuite-generate-needs-bash.patch
new file mode 100644
index 0000000000..1f289565e2
--- /dev/null
+++ b/cleopatre/buildroot/package/ltp-testsuite/ltp-testsuite-generate-needs-bash.patch
@@ -0,0 +1,8 @@
+--- ltp-full-20061121/testcases/network/generate.sh.orig 2006-12-07 22:21:56.000000000 -0700
++++ ltp-full-20061121/testcases/network/generate.sh 2006-12-07 22:22:05.000000000 -0700
+@@ -1,4 +1,4 @@
+-#!/bin/sh
++#!/bin/bash
+ #
+ # Copyright (c) International Business Machines Corp., 2001
+ #
diff --git a/cleopatre/buildroot/package/ltp-testsuite/ltp-testsuite-sh-is-not-C-code.patch b/cleopatre/buildroot/package/ltp-testsuite/ltp-testsuite-sh-is-not-C-code.patch
new file mode 100644
index 0000000000..a6f98ac13c
--- /dev/null
+++ b/cleopatre/buildroot/package/ltp-testsuite/ltp-testsuite-sh-is-not-C-code.patch
@@ -0,0 +1,11 @@
+--- ltp-full-20061121/IDcheck.sh.orig 2006-12-07 22:31:29.000000000 -0700
++++ ltp-full-20061121/IDcheck.sh 2006-12-07 22:32:58.000000000 -0700
+@@ -85,7 +85,7 @@
+ fi
+
+ whoami | grep root > /dev/null
+-if [ $? == "0" ]; then
++if [ $? = "0" ]; then
+ I_AM_ROOT=1
+ fi
+
diff --git a/cleopatre/buildroot/package/ltp-testsuite/ltp-testsuite.mk b/cleopatre/buildroot/package/ltp-testsuite/ltp-testsuite.mk
new file mode 100644
index 0000000000..1cc8ff7de7
--- /dev/null
+++ b/cleopatre/buildroot/package/ltp-testsuite/ltp-testsuite.mk
@@ -0,0 +1,69 @@
+#############################################################
+#
+# ltp-testsuite
+#
+#############################################################
+LTP_TESTSUITE_VERSION:=20070228
+LTP_TESTSUITE_SOURCE:=ltp-full-$(LTP_TESTSUITE_VERSION).tgz
+LTP_TESTSUITE_SITE:=http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/ltp
+LTP_TESTSUITE_CAT:=$(ZCAT)
+LTP_TESTSUITE_ROOT:=$(TARGET_DIR)/root
+LTP_TESTSUITE_DIR:=$(LTP_TESTSUITE_ROOT)/ltp-full-$(LTP_TESTSUITE_VERSION)
+
+#
+# Enable patches based upon different toolchain configuration options.
+#
+LTP_PATCHES:=ltp-testsuite-generate-needs-bash.patch \
+ ltp-testsuite-sh-is-not-C-code.patch \
+ ltp-testsuite.patch
+
+ifeq ($(BR2_PTHREADS_NATIVE),y)
+LTP_PATCHES+=ltp-testsuite-enable-openposix-for-nptl.patch
+endif
+ifeq ($(BR2_EXT_PTHREADS_NATIVE),y)
+LTP_PATCHES+=ltp-testsuite-enable-openposix-for-nptl.patch
+endif
+ifneq ($(BR2_INET_IPV6),y)
+LTP_PATCHES+=ltp-testsuite-disable-ipv6-tests.patch
+endif
+
+$(DL_DIR)/$(LTP_TESTSUITE_SOURCE):
+ $(WGET) -P $(DL_DIR) $(LTP_TESTSUITE_SITE)/$(LTP_TESTSUITE_SOURCE)
+
+ltp-testsuite-source: $(DL_DIR)/$(LTP_TESTSUITE_SOURCE)
+
+$(LTP_TESTSUITE_DIR)/Makefile: $(DL_DIR)/$(LTP_TESTSUITE_SOURCE)
+ mkdir -p $(LTP_TESTSUITE_ROOT)
+ $(LTP_TESTSUITE_CAT) $(DL_DIR)/$(LTP_TESTSUITE_SOURCE) | tar -C $(LTP_TESTSUITE_ROOT) $(TAR_OPTIONS) -
+ toolchain/patch-kernel.sh $(LTP_TESTSUITE_DIR) package/ltp-testsuite/ $(LTP_PATCHES)
+ touch -c $@
+
+$(LTP_TESTSUITE_DIR)/.compiled: $(LTP_TESTSUITE_DIR)/Makefile
+ $(MAKE1) $(TARGET_CONFIGURE_OPTS) CROSS_COMPILER=$(TARGET_CROSS) \
+ -C $(LTP_TESTSUITE_DIR) all
+ touch $@
+
+$(LTP_TESTSUITE_DIR)/.installed: $(LTP_TESTSUITE_DIR)/.compiled
+ # Use fakeroot to pretend to do 'make install' as root
+ echo '$(MAKE1) $(TARGET_CONFIGURE_OPTS) CROSS_COMPILER=$(TARGET_CROSS) ' \
+ '-C $(LTP_TESTSUITE_DIR) install' \
+ > $(PROJECT_BUILD_DIR)/.fakeroot.ltp
+ touch $@
+
+ltp-testsuite: uclibc host-fakeroot $(LTP_TESTSUITE_DIR)/.installed
+
+ltp-testsuite-clean:
+ -$(MAKE) -C $(LTP_TESTSUITE_DIR) clean
+
+ltp-testsuite-dirclean:
+ rm -rf $(LTP_TESTSUITE_DIR)
+
+
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(strip $(BR2_PACKAGE_LTP-TESTSUITE)),y)
+TARGETS+=ltp-testsuite
+endif
diff --git a/cleopatre/buildroot/package/ltp-testsuite/ltp-testsuite.patch b/cleopatre/buildroot/package/ltp-testsuite/ltp-testsuite.patch
new file mode 100644
index 0000000000..ce6cff3eab
--- /dev/null
+++ b/cleopatre/buildroot/package/ltp-testsuite/ltp-testsuite.patch
@@ -0,0 +1,73 @@
+diff -ur ltp-full-20061121/testcases/kernel/syscalls/fmtmsg/Makefile ltp-full-20061121-patched/testcases/kernel/syscalls/fmtmsg/Makefile
+--- ltp-full-20061121/testcases/kernel/syscalls/fmtmsg/Makefile 2006-11-21 14:31:28.000000000 -0600
++++ ltp-full-20061121-patched/testcases/kernel/syscalls/fmtmsg/Makefile 2006-12-02 00:16:36.830948316 -0600
+@@ -20,7 +20,7 @@
+ LDLIBS += -L../../../../lib -lltp
+
+ SRCS = $(wildcard *.c)
+-TARGETS = $(patsubst %.c,%,$(SRCS))
++TARGETS =#$(patsubst %.c,%,$(SRCS))
+
+ all: $(TARGETS)
+
+diff -ur ltp-full-20061121/testcases/kernel/syscalls/getcontext/Makefile ltp-full-20061121-patched/testcases/kernel/syscalls/getcontext/Makefile
+--- ltp-full-20061121/testcases/kernel/syscalls/getcontext/Makefile 2006-11-21 14:31:27.000000000 -0600
++++ ltp-full-20061121-patched/testcases/kernel/syscalls/getcontext/Makefile 2006-12-02 00:16:50.072004501 -0600
+@@ -20,7 +20,7 @@
+ LDLIBS += -L../../../../lib -lltp
+
+ SRCS = $(wildcard *.c)
+-TARGETS = $(patsubst %.c,%,$(SRCS))
++TARGETS =#$(patsubst %.c,%,$(SRCS))
+
+ all: $(TARGETS)
+
+diff -ur ltp-full-20061121/testcases/kernel/syscalls/profil/Makefile ltp-full-20061121-patched/testcases/kernel/syscalls/profil/Makefile
+--- ltp-full-20061121/testcases/kernel/syscalls/profil/Makefile 2006-11-21 14:31:28.000000000 -0600
++++ ltp-full-20061121-patched/testcases/kernel/syscalls/profil/Makefile 2006-12-02 00:17:03.301059744 -0600
+@@ -20,7 +20,7 @@
+ LDLIBS += -L../../../../lib -lltp
+
+ SRCS = $(wildcard *.c)
+-TARGETS = $(patsubst %.c,%,$(SRCS))
++TARGETS =#$(patsubst %.c,%,$(SRCS))
+
+ all: $(TARGETS)
+
+diff -ur ltp-full-20061121/testcases/kernel/syscalls/pselect/Makefile ltp-full-20061121-patched/testcases/kernel/syscalls/pselect/Makefile
+--- ltp-full-20061121/testcases/kernel/syscalls/pselect/Makefile 2006-11-21 14:31:29.000000000 -0600
++++ ltp-full-20061121-patched/testcases/kernel/syscalls/pselect/Makefile 2006-12-02 00:17:14.661965984 -0600
+@@ -20,7 +20,7 @@
+ LDLIBS += -L../../../../lib -lltp
+
+ SRCS = $(wildcard *.c)
+-TARGETS = $(patsubst %.c,%,$(SRCS))
++TARGETS =#$(patsubst %.c,%,$(SRCS))
+
+ all: $(TARGETS)
+
+diff -ur ltp-full-20061121/testcases/kernel/syscalls/swapon/swapon02.c ltp-full-20061121-patched/testcases/kernel/syscalls/swapon/swapon02.c
+--- ltp-full-20061121/testcases/kernel/syscalls/swapon/swapon02.c 2006-11-21 14:31:29.000000000 -0600
++++ ltp-full-20061121-patched/testcases/kernel/syscalls/swapon/swapon02.c 2006-12-02 00:18:12.422573631 -0600
+@@ -85,9 +85,7 @@
+ #include <sys/wait.h>
+ #include <sys/stat.h>
+ #include <sys/swap.h>
+-#ifdef OLDER_DISTRO_RELEASE
+-#include <linux/swap.h>
+-#endif
++#define MAX_SWAPFILES 32
+ #include <fcntl.h>
+ #include <pwd.h>
+ #include <string.h>
+@@ -96,10 +94,6 @@
+ #include "test.h"
+ #include "usctest.h"
+
+-#ifndef OLDER_DISTRO_RELEASE
+-#define MAX_SWAPFILES 32
+-#endif
+-
+ static void setup();
+ static void cleanup();
+ static int setup01();