summaryrefslogtreecommitdiff
path: root/cleopatre/buildroot/package/libspid/libspid.mk
diff options
context:
space:
mode:
Diffstat (limited to 'cleopatre/buildroot/package/libspid/libspid.mk')
-rw-r--r--cleopatre/buildroot/package/libspid/libspid.mk67
1 files changed, 67 insertions, 0 deletions
diff --git a/cleopatre/buildroot/package/libspid/libspid.mk b/cleopatre/buildroot/package/libspid/libspid.mk
new file mode 100644
index 0000000000..54e7f11bd5
--- /dev/null
+++ b/cleopatre/buildroot/package/libspid/libspid.mk
@@ -0,0 +1,67 @@
+#############################################################
+#
+# LibSPiD (provides SPiDCOM APIs needed by applications)
+# (works only under SPiDCOM SPC300 board)
+#
+#############################################################
+# Copyright (C) 2009 by SPiDCOM technologies
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU Library General Public License as
+# published by the Free Software Foundation; either version 2 of the
+# License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Library General Public License for more details.
+#
+# You should have received a copy of the GNU Library General Public
+# License along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+# USA
+#
+
+LIBSPID_VERSION_MSB:=0
+LIBSPID_VERSION:=$(LIBSPID_VERSION_MSB).0.1
+LIBSPID_SITE:=$(BASE_DIR)/../application/libspid
+LIBSPID_NAME:=libspid.so.$(LIBSPID_VERSION)
+LIBSPID_DIR:=$(BUILD_DIR)/libspid-$(LIBSPID_VERSION)
+
+libspid-source:
+
+$(LIBSPID_DIR)/.unpacked:
+ ln -s $(LIBSPID_SITE) $(LIBSPID_DIR)
+ touch $(LIBSPID_DIR)/.unpacked
+
+$(LIBSPID_DIR)/.configured: $(LIBSPID_DIR)/.unpacked
+ touch $(LIBSPID_DIR)/.configured
+
+$(LIBSPID_DIR)/liblibspid.so: $(LIBSPID_DIR)/.configured
+ (cd $(LIBSPID_DIR); $(TARGET_CONFIGURE_OPTS) $(MAKE) libspid.so LINUX_DIR="$(BASE_DIR)/../linux-2.6.25.10-spc300")
+
+$(TARGET_DIR)/usr/lib/$(LIBSPID_NAME): $(LIBSPID_DIR)/libspid.so
+ mkdir -p $(TARGET_DIR)/usr/lib
+ cp $< $@
+ (cd $(TARGET_DIR)/usr/lib; \
+ ln -fs $(LIBSPID_NAME) libmme.so; \
+ ln -fs $(LIBSPID_NAME) libmme.so.$(LIBSPID_VERSION_MSB))
+
+libspid: uclibc $(TARGET_DIR)/usr/lib/$(LIBSPID_NAME)
+
+libspid-clean:
+ rm -f $(TARGET_DIR)/usr/lib/libspid.so
+ rm -f $(TARGET_DIR)/usr/lib/libspid.so.$(LIBSPID_VERSION_MSB)
+ rm -f $(TARGET_DIR)/usr/lib/$(LIBSPID_NAME)
+ -$(MAKE) -C $(LIBSPID_DIR) clean
+
+libspid-dirclean:
+ rm -f $(LIBSPID_DIR)
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(strip $(BR2_PACKAGE_LIBSPID)),y)
+TARGETS+=libspid
+endif