summaryrefslogtreecommitdiff
path: root/cleopatre/buildroot/package/cups
diff options
context:
space:
mode:
Diffstat (limited to 'cleopatre/buildroot/package/cups')
-rw-r--r--cleopatre/buildroot/package/cups/Config.in7
-rw-r--r--cleopatre/buildroot/package/cups/cups-1.3.5-mantohtml.patch11
-rw-r--r--cleopatre/buildroot/package/cups/cups-1.3.5-no-tests-man.patch13
-rw-r--r--cleopatre/buildroot/package/cups/cups.mk70
4 files changed, 101 insertions, 0 deletions
diff --git a/cleopatre/buildroot/package/cups/Config.in b/cleopatre/buildroot/package/cups/Config.in
new file mode 100644
index 0000000000..839d20140d
--- /dev/null
+++ b/cleopatre/buildroot/package/cups/Config.in
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_CUPS
+ bool "cups"
+ help
+ The Common Unix Print Subsystem
+
+ http://www.cups.org
+
diff --git a/cleopatre/buildroot/package/cups/cups-1.3.5-mantohtml.patch b/cleopatre/buildroot/package/cups/cups-1.3.5-mantohtml.patch
new file mode 100644
index 0000000000..e6a10b0d01
--- /dev/null
+++ b/cleopatre/buildroot/package/cups/cups-1.3.5-mantohtml.patch
@@ -0,0 +1,11 @@
+--- cups-1.3.5/man/Makefile 2007-07-12 21:01:14.000000000 -0400
++++ cups-1.3.5/man/Makefile 2008-02-11 08:55:24.000000000 -0500
+@@ -173,7 +173,7 @@ html: $(MAN1) $(MAN5) $(MAN7) $(MAN8) ma
+ done
+
+ mantohtml: mantohtml.o
+- $(CC) $(LDFLAGS) -o $@ mantohtml.o
++ gcc -I/usr/include -I../ -L/usr/lib mantohtml.c -o mantohtml
+
+
+ #
diff --git a/cleopatre/buildroot/package/cups/cups-1.3.5-no-tests-man.patch b/cleopatre/buildroot/package/cups/cups-1.3.5-no-tests-man.patch
new file mode 100644
index 0000000000..567c801c64
--- /dev/null
+++ b/cleopatre/buildroot/package/cups/cups-1.3.5-no-tests-man.patch
@@ -0,0 +1,13 @@
+--- cups-1.3.5/Makefile 2007-12-06 15:09:39.000000000 -0500
++++ cups-1.3.5/Makefile 2008-02-09 21:53:03.000000000 -0500
+@@ -19,8 +19,8 @@ include Makedefs
+ # Directories to make...
+ #
+
+-DIRS = cups backend berkeley cgi-bin filter locale man monitor \
+- notifier $(PDFTOPS) scheduler systemv test \
++DIRS = cups backend berkeley cgi-bin filter locale monitor \
++ notifier $(PDFTOPS) scheduler systemv \
+ $(PHPDIR) \
+ conf data doc $(FONTS) ppd templates
+
diff --git a/cleopatre/buildroot/package/cups/cups.mk b/cleopatre/buildroot/package/cups/cups.mk
new file mode 100644
index 0000000000..b902a21186
--- /dev/null
+++ b/cleopatre/buildroot/package/cups/cups.mk
@@ -0,0 +1,70 @@
+################################################################################
+#
+# cups
+#
+################################################################################
+CUPS_VERSION = 1.3.5
+CUPS_NAME = cups-$(CUPS_VERSION)
+CUPS_DIR = $(BUILD_DIR)/$(CUPS_NAME)
+CUPS_SITE = http://ftp.easysw.com/pub/cups/1.3.5
+CUPS_SOURCE:=$(CUPS_NAME)-source.tar.bz2
+CUPS_DESTDIR:=$(STAGING_DIR)/usr/lib
+CUPS_CAT:=$(BZCAT)
+
+ifeq ($(BR2_PACKAGE_DBUS),y)
+ CUPS_CONF_OPT_DBUS =--enable-dbus
+ CUPS_DEPENDENCIES_DBUS = dbus
+else
+ CUPS_CONF_OPT_DBUS =--disable-dbus
+endif
+
+ifneq ($(BR2_PACKAGE_XSERVER_none),y)
+ CUPS_DEPENDENCIES_X = xlib_libX11
+endif
+
+$(DL_DIR)/$(CUPS_SOURCE):
+ $(WGET) -P $(DL_DIR) $(CUPS_SITE)/$(CUPS_SOURCE)
+
+$(CUPS_DIR)/.unpacked: $(DL_DIR)/$(CUPS_SOURCE)
+ $(CUPS_CAT) $(DL_DIR)/$(CUPS_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
+ toolchain/patch-kernel.sh $(CUPS_DIR) package/cups/ \*.patch
+ $(CONFIG_UPDATE) $(CUPS_DIR)
+ touch $@
+
+$(CUPS_DIR)/.configured: $(CUPS_DIR)/.unpacked
+ (cd $(CUPS_DIR) && \
+ $(TARGET_CONFIGURE_OPTS) \
+ $(TARGET_CONFIGURE_ARGS) \
+ ./configure \
+ --prefix=/usr $(CUPS_CONF_OPT_DBUS) --includedir=/usr/include \
+ --libdir=/usr/lib --disable-gnutls --disable-gssapi --host=$(ARCH) \ )
+ touch $@
+
+$(CUPS_DIR)/.compiled: $(CUPS_DIR)/.configured
+ $(MAKE) -C $(CUPS_DIR) cups backend berkeley cgi-bin filter \
+ locale monitor notifier pdftops scheduler systemv scripting/php \
+ conf data doc fonts ppd templates
+ touch $@
+
+$(CUPS_DIR)/.installed: $(CUPS_DIR)/.compiled
+ $(MAKE) -C $(CUPS_DIR) DESTDIR=$(STAGING_DIR) DSTROOT=$(STAGING_DIR) install
+ $(MAKE) -C $(CUPS_DIR) DESTDIR=$(TARGET_DIR) DSTROOT=$(TARGET_DIR) install
+ $(SED) "s,^prefix=.*,prefix=\'$(STAGING_DIR)/usr\',g" $(STAGING_DIR)/usr/bin/cups-config
+ $(SED) "s,^exec_prefix=.*,exec_prefix=\'$(STAGING_DIR)/usr\',g" $(STAGING_DIR)/usr/bin/cups-config
+ $(SED) "s,^includedir=.*,includedir=\'$(STAGING_DIR)/usr/include\',g" $(STAGING_DIR)/usr/bin/cups-config
+ $(SED) "s,^libdir=.*,libdir=\'$(STAGING_DIR)/usr/lib\',g" $(STAGING_DIR)/usr/bin/cups-config
+ touch $@
+
+cups: uclibc $(CUPS_DEPENDENCIES_DBUS) $(CUPS_DEPENDENCIES_X) $(CUPS_DIR)/.installed
+
+cups-clean:
+ -$(MAKE) -C $(CUPS_DIR) clean
+
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(strip $(BR2_PACKAGE_CUPS)),y)
+TARGETS+=cups
+endif \ No newline at end of file