summaryrefslogtreecommitdiff
path: root/cleopatre/buildroot
diff options
context:
space:
mode:
authorYacine Belkadi2013-03-01 15:42:24 +0100
committerYacine Belkadi2013-03-06 15:36:28 +0100
commitebb22fc904aa06daa47b6648f1b3142dd26ac6ce (patch)
tree91bdc53d8f852dfe55014446bd0de33e91cac1f1 /cleopatre/buildroot
parent4a419e4cb576660fd47b8be5fa5a7eef3b0add05 (diff)
cleo/buildroot/target/Spidcom: remove mse500, closes #3820
"MSE500" is the name of the chip. Having a target with that name is confusing. In addition, this target was actually used for the MSK500 board. But an msk500 target has been added by a previous commit. So this target is not needed anymore. Remove it.
Diffstat (limited to 'cleopatre/buildroot')
-rw-r--r--cleopatre/buildroot/Makefile1
-rw-r--r--cleopatre/buildroot/target/device/Spidcom/Config.in8
-rw-r--r--cleopatre/buildroot/target/device/Spidcom/common/defconfig.base1
-rw-r--r--cleopatre/buildroot/target/device/Spidcom/common/linux26.config.base1
-rw-r--r--cleopatre/buildroot/target/device/Spidcom/targets/mse500/defconfig.part4
-rw-r--r--cleopatre/buildroot/target/device/Spidcom/targets/mse500/desc18
-rw-r--r--cleopatre/buildroot/target/device/Spidcom/targets/mse500/linux26.config.part15
-rw-r--r--cleopatre/buildroot/target/device/Spidcom/targets/mse500/target_skeleton_add/etc/network/interfaces24
8 files changed, 0 insertions, 72 deletions
diff --git a/cleopatre/buildroot/Makefile b/cleopatre/buildroot/Makefile
index 0fd7fa7fbd..59c394b429 100644
--- a/cleopatre/buildroot/Makefile
+++ b/cleopatre/buildroot/Makefile
@@ -515,7 +515,6 @@ help:
@echo ' mcr500_defconfig - default HPAV configuration for MCR500 boards'
@echo ' mcr510_defconfig - default HPAV configuration for MCR510 boards'
@echo ' mpr520_defconfig - default HPAV configuration for MPR520 boards'
- @echo ' mse500_defconfig - default HPAV configuration for MSE500 300 boards'
@echo ' mse500dini_300_defconfig - default HPAV configuration for MSE500 DINI 300 boards'
@echo ' msk500_defconfig - default HPAV configuration for MSK500 300 boards'
@echo ' scr300_defconfig - default HPAV configuration for SCR300 boards'
diff --git a/cleopatre/buildroot/target/device/Spidcom/Config.in b/cleopatre/buildroot/target/device/Spidcom/Config.in
index 7932e75405..287a4d4a6b 100644
--- a/cleopatre/buildroot/target/device/Spidcom/Config.in
+++ b/cleopatre/buildroot/target/device/Spidcom/Config.in
@@ -38,13 +38,6 @@ config BR2_TARGET_SPIDCOM_MPR520
help
Support for the MPR520 AV reference design
-config BR2_TARGET_SPIDCOM_MSE500
- bool "MSE500 development board"
- depends on BR2_arm
- select BR2_TARGET_SPIDCOM_ARCH_MSE500
- help
- Support for the MSE500 (300 mode)
-
config BR2_TARGET_SPIDCOM_MSE500DINI_300
bool "MSE500DINI_300 development board"
depends on BR2_arm
@@ -132,7 +125,6 @@ config BR2_TARGET_SPIDCOM_BOARD
default "mcr500" if BR2_TARGET_SPIDCOM_MCR500
default "mcr510" if BR2_TARGET_SPIDCOM_MCR510
default "mpr520" if BR2_TARGET_SPIDCOM_MPR520
- default "mse500" if BR2_TARGET_SPIDCOM_MSE500
default "mse500dini_300" if BR2_TARGET_SPIDCOM_MSE500DINI_300
default "msk500" if BR2_TARGET_SPIDCOM_MSK500
default "scr300" if BR2_TARGET_SPIDCOM_SCR300
diff --git a/cleopatre/buildroot/target/device/Spidcom/common/defconfig.base b/cleopatre/buildroot/target/device/Spidcom/common/defconfig.base
index c5237d9720..dc744b01d7 100644
--- a/cleopatre/buildroot/target/device/Spidcom/common/defconfig.base
+++ b/cleopatre/buildroot/target/device/Spidcom/common/defconfig.base
@@ -60,7 +60,6 @@ BR2_TARGET_SPIDCOM=y
# BR2_TARGET_SPIDCOM_MCR500 is not set
# BR2_TARGET_SPIDCOM_MCR510 is not set
# BR2_TARGET_SPIDCOM_MPR520 is not set
-# BR2_TARGET_SPIDCOM_MSE500 is not set
# BR2_TARGET_SPIDCOM_MSE500DINI_300 is not set
# BR2_TARGET_SPIDCOM_MSK500 is not set
# BR2_TARGET_SPIDCOM_SCR300 is not set
diff --git a/cleopatre/buildroot/target/device/Spidcom/common/linux26.config.base b/cleopatre/buildroot/target/device/Spidcom/common/linux26.config.base
index 1d3c66994e..f39e8ac2e8 100644
--- a/cleopatre/buildroot/target/device/Spidcom/common/linux26.config.base
+++ b/cleopatre/buildroot/target/device/Spidcom/common/linux26.config.base
@@ -128,7 +128,6 @@ CONFIG_ARCH_SPC300=y
# CONFIG_MACH_MCR500 is not set
# CONFIG_MACH_MCR510 is not set
# CONFIG_MACH_MPR520 is not set
-# CONFIG_MACH_MSE500 is not set
# CONFIG_MACH_MSE500DINI_300 is not set
# CONFIG_MACH_MSK500 is not set
# CONFIG_MACH_SCR300 is not set
diff --git a/cleopatre/buildroot/target/device/Spidcom/targets/mse500/defconfig.part b/cleopatre/buildroot/target/device/Spidcom/targets/mse500/defconfig.part
deleted file mode 100644
index 7c83bf4495..0000000000
--- a/cleopatre/buildroot/target/device/Spidcom/targets/mse500/defconfig.part
+++ /dev/null
@@ -1,4 +0,0 @@
-BR2_PROJECT="mse500"
-BR2_HOSTNAME="mse500"
-BR2_TARGET_SPIDCOM_MSE500=y
-BR2_PACKAGE_PMD=y
diff --git a/cleopatre/buildroot/target/device/Spidcom/targets/mse500/desc b/cleopatre/buildroot/target/device/Spidcom/targets/mse500/desc
deleted file mode 100644
index b8c9980e97..0000000000
--- a/cleopatre/buildroot/target/device/Spidcom/targets/mse500/desc
+++ /dev/null
@@ -1,18 +0,0 @@
-busybox.config
- common/busybox.config.base
-
-defconfig
- common/defconfig.base
- local/defconfig.part
-
-device_table.txt
- common/device_table.txt
-
-linux26.config
- common/linux26.config.base
- common/linux26.config.chip_mse500
- local/linux26.config.part
-
-target_skeleton
- common/target_skeleton_base
- local/target_skeleton_add
diff --git a/cleopatre/buildroot/target/device/Spidcom/targets/mse500/linux26.config.part b/cleopatre/buildroot/target/device/Spidcom/targets/mse500/linux26.config.part
deleted file mode 100644
index aa4d98f139..0000000000
--- a/cleopatre/buildroot/target/device/Spidcom/targets/mse500/linux26.config.part
+++ /dev/null
@@ -1,15 +0,0 @@
-CONFIG_MACH_MSE500=y
-
-#
-# Power management options
-#
-CONFIG_PM=y
-# CONFIG_PM_LEGACY is not set
-# CONFIG_PM_DEBUG is not set
-CONFIG_PM_SLEEP=y
-CONFIG_SUSPEND=y
-CONFIG_SUSPEND_FREEZER=y
-# CONFIG_APM_EMULATION is not set
-
-CONFIG_REALTEK_PHY=y
-CONFIG_NETDEV_1000=y
diff --git a/cleopatre/buildroot/target/device/Spidcom/targets/mse500/target_skeleton_add/etc/network/interfaces b/cleopatre/buildroot/target/device/Spidcom/targets/mse500/target_skeleton_add/etc/network/interfaces
deleted file mode 100644
index e9d802edf4..0000000000
--- a/cleopatre/buildroot/target/device/Spidcom/targets/mse500/target_skeleton_add/etc/network/interfaces
+++ /dev/null
@@ -1,24 +0,0 @@
-auto lo eth0 plc0 br0
-
-# Configure Loopback
-iface lo inet loopback
-
-# Configure Ethernet interface
-iface eth0 inet static
- address 0.0.0.0
- netmask 255.255.255.255
-
-iface plc0 inet static
- address 0.0.0.0
- netmask 255.255.255.255
-
-iface br0 inet static
- address 10.3.11.1
- netmask 255.255.0.0
- pre-up brctl addbr br0
- pre-up brctl addif br0 eth0
- pre-up brctl addif br0 plc0
- pre-up brctl setfd br0 1
- post-down brctl delif br0 eth0
- post-down brctl delif br0 plc0
- post-down brctl delbr br0