summaryrefslogtreecommitdiff
path: root/cleopatre/buildroot
diff options
context:
space:
mode:
authorlefranc2009-10-16 12:04:22 +0000
committerlefranc2009-10-16 12:04:22 +0000
commit67b8a1f9fd5867f2ec6f8f6a9f57028846711138 (patch)
tree7b15d1abbd630fd312bb7745b214916f08357f49 /cleopatre/buildroot
parent08cf0d2c456cdfaf98f88f4ec0e37ca2b87ec5a9 (diff)
cleo/buildroot: change plc package to plcdrv
plc package is reserved for the new "plc" utility (in application directory) git-svn-id: svn+ssh://pessac/svn/cesar/trunk@6155 017c9cb6-072f-447c-8318-d5b54f68fe89
Diffstat (limited to 'cleopatre/buildroot')
-rw-r--r--cleopatre/buildroot/package/Config.in3
-rw-r--r--cleopatre/buildroot/package/plc/Config.in2
-rw-r--r--cleopatre/buildroot/package/plc/plc.mk58
-rw-r--r--cleopatre/buildroot/package/plcdrv/Config.in6
-rw-r--r--cleopatre/buildroot/package/plcdrv/plcdrv.mk94
-rw-r--r--cleopatre/buildroot/target/device/Spidcom/spk300g_defconfig1
6 files changed, 121 insertions, 43 deletions
diff --git a/cleopatre/buildroot/package/Config.in b/cleopatre/buildroot/package/Config.in
index 0227ee8385..172c68d8fc 100644
--- a/cleopatre/buildroot/package/Config.in
+++ b/cleopatre/buildroot/package/Config.in
@@ -32,7 +32,7 @@ endif
# bool "Common Applications"
# default y
# help
-# A set of applications, utilities and libraries for
+# A set of applications, utilities and libraries for
# text processing, toolchain generation and other things.
@@ -221,6 +221,7 @@ source "package/openvpn/Config.in"
source "package/openswan/Config.in"
if BR2_TARGET_SPIDCOM
source "package/plc/Config.in"
+source "package/plcdrv/Config.in"
endif
source "package/portmap/Config.in"
source "package/pppd/Config.in"
diff --git a/cleopatre/buildroot/package/plc/Config.in b/cleopatre/buildroot/package/plc/Config.in
index 6cd5cb1237..0b2e28d7ce 100644
--- a/cleopatre/buildroot/package/plc/Config.in
+++ b/cleopatre/buildroot/package/plc/Config.in
@@ -1,6 +1,6 @@
config BR2_PACKAGE_PLC
bool "plc"
help
- SPiDCOM Technologies Power Line Communications utilities for SPC300 board : driver and daemon.
+ Utility program for managing PLC on SPC300 board.
http://www.spidcom.com
diff --git a/cleopatre/buildroot/package/plc/plc.mk b/cleopatre/buildroot/package/plc/plc.mk
index ce3204b658..4ecd2ac32b 100644
--- a/cleopatre/buildroot/package/plc/plc.mk
+++ b/cleopatre/buildroot/package/plc/plc.mk
@@ -1,6 +1,6 @@
#############################################################
#
-# plc (provides PLC applications)
+# plc (provides utilities for managing PLC on SPC300 boards)
# (works only under SPiDCOM SPC300 board)
#
#############################################################
@@ -22,41 +22,10 @@
# USA
#
-PLC_DEV_SITE:=$(BASE_DIR)/../devkit
-IS_PLC_DEV:=$(shell [ -d $(PLC_DEV_SITE) ] && echo y || echo n)
-
PLC_VERSION:=0.0.1
+PLC_SITE:=$(BASE_DIR)/../application/plc
PLC_NAME:=plc-$(PLC_VERSION)
PLC_DIR:=$(BUILD_DIR)/plc-$(PLC_VERSION)
-ifeq ($(IS_PLC_DEV),y)
- PLC_SITE:=$(PLC_DEV_SITE)
- PLCD_OBJPATH:=$(PLC_DIR)/plcd
- PLCDRV_OBJPATH:=$(PLC_DIR)/plcdrv/arm
- PLCD_MAKE:=plcd-dev-make
- PLCDRV_MAKE:=plcdrv-dev-make
- DEV_CLEAN:=plcd-dev-clean plcdrv-dev-clean
-else
- PLC_SITE:=$(BASE_DIR)/../binaries
- PLCD_OBJPATH:=$(PLC_DIR)
- PLCDRV_OBJPATH:=$(PLC_DIR)
- PLCD_MAKE:=
- PLCDRV_MAKE:=
- DEV_CLEAN:=
-endif
-
-plcd-dev-make:
- (cd $(PLC_DIR); $(TARGET_CONFIGURE_OPTS) $(MAKE) plcd LINUX_DIR="$(BASE_DIR)/../linux-2.6.25.10-spc300")
-
-plcdrv-dev-make:
- (cd $(PLC_DIR); $(TARGET_CONFIGURE_OPTS) $(MAKE) plcdrv LINUX_DIR="$(BASE_DIR)/../linux-2.6.25.10-spc300")
-
-plcd-dev-clean:
- -$(MAKE) -C $(PLC_DIR) clean-plcd
-
-plcdrv-dev-clean:
- -$(MAKE) -C $(PLC_DIR) clean-plcdrv
-
-
plc-source:
@@ -67,20 +36,27 @@ $(PLC_DIR)/.unpacked:
$(PLC_DIR)/.configured: $(PLC_DIR)/.unpacked
touch $(PLC_DIR)/.configured
-$(PLCD_OBJPATH)/plcd: $(PLC_DIR)/.configured $(PLCD_MAKE)
-
-$(PLCDRV_OBJPATH)/plcdrv.ko: $(PLC_DIR)/.configured $(PLCDRV_MAKE)
+$(PLC_DIR)/plc: $(PLC_DIR)/.configured
+ (cd $(PLC_DIR); \
+ $(TARGET_CONFIGURE_OPTS) $(MAKE) LINUX_DIR="$(BASE_DIR)/../linux-2.6.25.10-spc300" \
+ LIBMME_DIR="$(BASE_DIR)/../application/libmme" \
+ LIBSPID_DIR="$(BASE_DIR)/../application/libspid")
-$(TARGET_DIR)/usr/sbin/plcd: $(PLCD_OBJPATH)/plcd
+$(TARGET_DIR)/usr/bin/plc: $(PLC_DIR)/plc
+ mkdir -p $(TARGET_DIR)/usr/bin
cp $< $@
-$(TARGET_DIR)/lib/modules/plcdrv.ko: $(PLCDRV_OBJPATH)/plcdrv.ko
+$(TARGET_DIR)/etc/init.d/S99plc: $(PLC_DIR)/S99plc
+ mkdir -p $(TARGET_DIR)/etc/init.d
cp $< $@
+ chmod a+x $@
-plc: uclibc $(TARGET_DIR)/usr/sbin/plcd $(TARGET_DIR)/lib/modules/plcdrv.ko
+plc: uclibc $(TARGET_DIR)/usr/bin/plc $(TARGET_DIR)/etc/init.d/S99plc
-plc-clean: $(DEV_CLEAN)
- rm -f $(TARGET_DIR)/usr/sbin/plcd $(TARGET_DIR)/lib/modules/plcdrv.ko
+plc-clean:
+ rm -f $(TARGET_DIR)/usr/bin/plc
+ rm -f $(TARGET_DIR)/etc/init.d/S99plc
+ -$(MAKE) -C $(PLC_DIR) clean
plc-dirclean:
rm -f $(PLC_DIR)
diff --git a/cleopatre/buildroot/package/plcdrv/Config.in b/cleopatre/buildroot/package/plcdrv/Config.in
new file mode 100644
index 0000000000..6cd5cb1237
--- /dev/null
+++ b/cleopatre/buildroot/package/plcdrv/Config.in
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_PLC
+ bool "plc"
+ help
+ SPiDCOM Technologies Power Line Communications utilities for SPC300 board : driver and daemon.
+
+ http://www.spidcom.com
diff --git a/cleopatre/buildroot/package/plcdrv/plcdrv.mk b/cleopatre/buildroot/package/plcdrv/plcdrv.mk
new file mode 100644
index 0000000000..da21aa0fca
--- /dev/null
+++ b/cleopatre/buildroot/package/plcdrv/plcdrv.mk
@@ -0,0 +1,94 @@
+#############################################################
+#
+# plc (provides PLC applications)
+# (works only under SPiDCOM SPC300 board)
+#
+#############################################################
+# Copyright (C) 2009 by SPiDCOM technologies
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU Library General Public License as
+# published by the Free Software Foundation; either version 2 of the
+# License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Library General Public License for more details.
+#
+# You should have received a copy of the GNU Library General Public
+# License along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+# USA
+#
+
+PLCDRV_DEV_SITE:=$(BASE_DIR)/../devkit
+IS_PLCDRV_DEV:=$(shell [ -d $(PLCDRV_DEV_SITE) ] && echo y || echo n)
+
+PLCDRV_VERSION:=0.0.1
+PLCDRV_NAME:=plc-$(PLCDRV_VERSION)
+PLCDRV_DIR:=$(BUILD_DIR)/plc-$(PLCDRV_VERSION)
+ifeq ($(IS_PLCDRV_DEV),y)
+ PLCDRV_SITE:=$(PLCDRV_DEV_SITE)
+ PLCDRVD_OBJPATH:=$(PLCDRV_DIR)/plcd
+ PLCDRVDRV_OBJPATH:=$(PLCDRV_DIR)/plcdrv/arm
+ PLCDRVD_MAKE:=plcd-dev-make
+ PLCDRVDRV_MAKE:=plcdrv-dev-make
+ DEV_CLEAN:=plcd-dev-clean plcdrv-dev-clean
+else
+ PLCDRV_SITE:=$(BASE_DIR)/../binaries
+ PLCDRVD_OBJPATH:=$(PLCDRV_DIR)
+ PLCDRVDRV_OBJPATH:=$(PLCDRV_DIR)
+ PLCDRVD_MAKE:=
+ PLCDRVDRV_MAKE:=
+ DEV_CLEAN:=
+endif
+
+plcd-dev-make:
+ (cd $(PLCDRV_DIR); $(TARGET_CONFIGURE_OPTS) $(MAKE) plcd LINUX_DIR="$(BASE_DIR)/../linux-2.6.25.10-spc300")
+
+plcdrv-dev-make:
+ (cd $(PLCDRV_DIR); $(TARGET_CONFIGURE_OPTS) $(MAKE) plcdrv LINUX_DIR="$(BASE_DIR)/../linux-2.6.25.10-spc300")
+
+plcd-dev-clean:
+ -$(MAKE) -C $(PLCDRV_DIR) clean-plcd
+
+plcdrv-dev-clean:
+ -$(MAKE) -C $(PLCDRV_DIR) clean-plcdrv
+
+
+
+plc-source:
+
+$(PLCDRV_DIR)/.unpacked:
+ ln -s $(PLCDRV_SITE) $(PLCDRV_DIR)
+ touch $(PLCDRV_DIR)/.unpacked
+
+$(PLCDRV_DIR)/.configured: $(PLCDRV_DIR)/.unpacked
+ touch $(PLCDRV_DIR)/.configured
+
+$(PLCDRVD_OBJPATH)/plcd: $(PLCDRV_DIR)/.configured $(PLCDRVD_MAKE)
+
+$(PLCDRVDRV_OBJPATH)/plcdrv.ko: $(PLCDRV_DIR)/.configured $(PLCDRVDRV_MAKE)
+
+$(TARGET_DIR)/usr/sbin/plcd: $(PLCDRVD_OBJPATH)/plcd
+ cp $< $@
+
+$(TARGET_DIR)/lib/modules/plcdrv.ko: $(PLCDRVDRV_OBJPATH)/plcdrv.ko
+ cp $< $@
+
+plc: uclibc $(TARGET_DIR)/usr/sbin/plcd $(TARGET_DIR)/lib/modules/plcdrv.ko
+
+plc-clean: $(DEV_CLEAN)
+ rm -f $(TARGET_DIR)/usr/sbin/plcd $(TARGET_DIR)/lib/modules/plcdrv.ko
+
+plc-dirclean:
+ rm -f $(PLCDRV_DIR)
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(strip $(BR2_PACKAGE_PLCDRV)),y)
+TARGETS+=plcdrv
+endif
diff --git a/cleopatre/buildroot/target/device/Spidcom/spk300g_defconfig b/cleopatre/buildroot/target/device/Spidcom/spk300g_defconfig
index 4964a9da81..e929b1f488 100644
--- a/cleopatre/buildroot/target/device/Spidcom/spk300g_defconfig
+++ b/cleopatre/buildroot/target/device/Spidcom/spk300g_defconfig
@@ -381,6 +381,7 @@ BR2_PACKAGE_OPENSSL=y
# BR2_PACKAGE_OPENSSL_TARGET_HEADERS is not set
# BR2_PACKAGE_OPENVPN is not set
# BR2_PACKAGE_OPENSWAN is not set
+BR2_PACKAGE_PLCDRV=y
BR2_PACKAGE_PLC=y
#