summaryrefslogtreecommitdiff
path: root/cleopatre/buildroot/toolchain/Makefile.in
diff options
context:
space:
mode:
authorlefranc2008-08-01 09:25:43 +0000
committerlefranc2008-08-01 09:25:43 +0000
commit9a2bcc0b92b392f1f21cd26927515e4d49bc128e (patch)
treed0bd193c764606c4c6e4b4568ef08d0ff3324b72 /cleopatre/buildroot/toolchain/Makefile.in
parentd0cc0304ed6eaf72116743e13e5b3b3cbfd878bb (diff)
- import of buildroot original sources (20080729 version)
git-svn-id: svn+ssh://pessac/svn/cesar/trunk@2704 017c9cb6-072f-447c-8318-d5b54f68fe89
Diffstat (limited to 'cleopatre/buildroot/toolchain/Makefile.in')
-rw-r--r--cleopatre/buildroot/toolchain/Makefile.in49
1 files changed, 49 insertions, 0 deletions
diff --git a/cleopatre/buildroot/toolchain/Makefile.in b/cleopatre/buildroot/toolchain/Makefile.in
new file mode 100644
index 0000000000..bdabde9adb
--- /dev/null
+++ b/cleopatre/buildroot/toolchain/Makefile.in
@@ -0,0 +1,49 @@
+ifeq ($(BR2_PTHREADS_NONE),y)
+THREADS:=--disable-threads
+else
+THREADS:=--enable-threads
+endif
+
+ifeq ($(BR2_ENABLE_MULTILIB),y)
+MULTILIB:=--enable-multilib
+else
+MULTILIB:=--disable-multilib
+endif
+
+ifeq ($(BR2_ENABLE_OPENMP),y)
+OPENMP:=--enable-openmp
+else
+OPENMP:=--disable-openmp
+endif
+
+
+ifeq ($(BR2_TOOLCHAIN_SYSROOT),y)
+BR2_SYSROOT_PREFIX=# nothing, straight into /usr
+BR2_SYSROOT_STAGING_DESTDIR=DESTDIR=$(STAGING_DIR)/
+BR2_SYSROOT_TARGET_DESTDIR=DESTDIR=$(TARGET_DIR)/
+BR2_CONFIGURE_DEVEL_SYSROOT=--with-sysroot=$(TOOL_BUILD_DIR)/uClibc_dev/
+BR2_CONFIGURE_STAGING_SYSROOT=--with-sysroot=$(STAGING_DIR)
+BR2_CONFIGURE_BUILD_TOOLS=--with-build-time-tools=$(STAGING_DIR)/usr/$(REAL_GNU_TARGET_NAME)/bin
+BR2_SYSROOT=--sysroot=$(STAGING_DIR)/
+BR2_ISYSROOT=-isysroot $(STAGING_DIR)
+else
+BR2_SYSROOT_PREFIX=$(STAGING_DIR)
+BR2_SYSROOT_STAGING_DESTDIR=# nothing
+BR2_SYSROOT_TARGET_DESTDIR=# nothing
+BR2_CONFIGURE_DEVEL_SYSROOT=--with-sysroot=$(TOOL_BUILD_DIR)/uClibc_dev/
+BR2_CONFIGURE_STAGING_SYSROOT=# nothing
+BR2_CONFIGURE_BUILD_TOOLS=# nothing
+BR2_SYSROOT=# nothing
+BR2_ISYSROOT=#nothing
+endif
+
+# FIXME -- this is temporary
+OPTIMIZE_FOR_CPU=$(ARCH)
+
+# late binding check to see if the target cc supports -fwhole-program
+CFLAGS_WHOLE_PROGRAM = $(call cc-option,-fwhole-program,)
+CFLAGS_COMBINE = $(call cc-option,-combine,)
+
+# gcc has a bunch of needed stuff....
+include toolchain/gcc/Makefile.in
+