summaryrefslogtreecommitdiff
path: root/cleopatre/buildroot/target
diff options
context:
space:
mode:
authorlefranc2009-07-09 11:57:59 +0000
committerlefranc2009-07-09 11:57:59 +0000
commita8f13f0d59175aa5d670e234ad250af5664bb3d9 (patch)
tree099098db0fc0d8cb7eb7458cf950eb6db64d31d7 /cleopatre/buildroot/target
parent9ec32ac81d4ec452ab1d92084570515da076b4c4 (diff)
[cleopatre][kernel] allow SPK300-G to compile and run on FCM3
[cleopatre][buildroot] fix some config files for SPK300-G git-svn-id: svn+ssh://pessac/svn/cesar/trunk@4922 017c9cb6-072f-447c-8318-d5b54f68fe89
Diffstat (limited to 'cleopatre/buildroot/target')
-rw-r--r--cleopatre/buildroot/target/device/Spidcom/Config.in20
-rw-r--r--cleopatre/buildroot/target/device/Spidcom/Makefile.in5
-rw-r--r--cleopatre/buildroot/target/device/Spidcom/arizona/linux26.config1
-rw-r--r--cleopatre/buildroot/target/device/Spidcom/arizona_defconfig1
-rw-r--r--cleopatre/buildroot/target/device/Spidcom/spk300g/linux26.config5
-rw-r--r--cleopatre/buildroot/target/device/Spidcom/spk300g_defconfig1
-rw-r--r--cleopatre/buildroot/target/linux/Makefile.in2
7 files changed, 29 insertions, 6 deletions
diff --git a/cleopatre/buildroot/target/device/Spidcom/Config.in b/cleopatre/buildroot/target/device/Spidcom/Config.in
index 165cdee05c..fdbc909d2e 100644
--- a/cleopatre/buildroot/target/device/Spidcom/Config.in
+++ b/cleopatre/buildroot/target/device/Spidcom/Config.in
@@ -5,12 +5,24 @@ menuconfig BR2_TARGET_SPIDCOM
if BR2_TARGET_SPIDCOM
comment "Spidcom Specific Device Support"
depends on BR2_arm
-
+
+choice
+ prompt "SPC300 target board"
+ default BR2_TARGET_SPIDCOM_SPK300G
+
config BR2_TARGET_SPIDCOM_ARIZONA
- bool "Board support for the Arizona development board"
+ bool "Arizona development board"
depends on BR2_arm
- default y
help
- Support for the Arizona SPCAV based device
+ Support for the Arizona SPC300 based device
+
+config BR2_TARGET_SPIDCOM_SPK300G
+ bool "SPK300-G development board"
+ depends on BR2_arm
+ help
+ Support for the SPK300-G SPC300 based device
+
+endchoice
+
endif
diff --git a/cleopatre/buildroot/target/device/Spidcom/Makefile.in b/cleopatre/buildroot/target/device/Spidcom/Makefile.in
index ea1527a40d..73d74bc9a8 100644
--- a/cleopatre/buildroot/target/device/Spidcom/Makefile.in
+++ b/cleopatre/buildroot/target/device/Spidcom/Makefile.in
@@ -3,7 +3,10 @@ ifeq ($(strip $(BR2_TARGET_SPIDCOM)),y)
ifeq ($(strip $(BR2_TARGET_SPIDCOM_ARIZONA)),y)
include target/device/Spidcom/arizona/Makefile.in
-#include target/device/Spidcom/arizona/linux.mk
+endif
+
+ifeq ($(strip $(BR2_TARGET_SPIDCOM_SPK300G)),y)
+include target/device/Spidcom/spk300g/Makefile.in
endif
BASE_TARGETS += check_linux_link
diff --git a/cleopatre/buildroot/target/device/Spidcom/arizona/linux26.config b/cleopatre/buildroot/target/device/Spidcom/arizona/linux26.config
index b06f1d96d0..8932a361a0 100644
--- a/cleopatre/buildroot/target/device/Spidcom/arizona/linux26.config
+++ b/cleopatre/buildroot/target/device/Spidcom/arizona/linux26.config
@@ -176,6 +176,7 @@ CONFIG_ARCH_SPC300=y
# SPC300 platform type
#
CONFIG_MACH_ARIZONA=y
+# CONFIG_MACH_SPK300G is not set
#
# Processor Type
diff --git a/cleopatre/buildroot/target/device/Spidcom/arizona_defconfig b/cleopatre/buildroot/target/device/Spidcom/arizona_defconfig
index 98b6d805c7..724667fa5d 100644
--- a/cleopatre/buildroot/target/device/Spidcom/arizona_defconfig
+++ b/cleopatre/buildroot/target/device/Spidcom/arizona_defconfig
@@ -69,6 +69,7 @@ BR2_TARGET_SPIDCOM=y
# Spidcom Specific Device Support
#
BR2_TARGET_SPIDCOM_ARIZONA=y
+# BR2_TARGET_SPIDCOM_SPK300G is not set
#
# Generic Architecture support
diff --git a/cleopatre/buildroot/target/device/Spidcom/spk300g/linux26.config b/cleopatre/buildroot/target/device/Spidcom/spk300g/linux26.config
index e9cfcfeb8e..f0a5db443b 100644
--- a/cleopatre/buildroot/target/device/Spidcom/spk300g/linux26.config
+++ b/cleopatre/buildroot/target/device/Spidcom/spk300g/linux26.config
@@ -175,7 +175,9 @@ CONFIG_ARCH_SPC300=y
#
# SPC300 platform type
#
+# CONFIG_MACH_ARIZONA is not set
CONFIG_MACH_SPK300G=y
+CONFIG_SPK300G_ON_FCM3=y
#
# Processor Type
@@ -476,7 +478,10 @@ CONFIG_MTD_CFI_UTIL=y
# CONFIG_MTD_COMPLEX_MAPPINGS is not set
# CONFIG_MTD_PHYSMAP is not set
# CONFIG_MTD_ARM_INTEGRATOR is not set
+# CONFIG_MTD_SPK300G_MAP_SMALL is not set
CONFIG_MTD_SPK300G_MAP_MEDIUM1=y
+# CONFIG_MTD_SPK300G_MAP_MEDIUM2 is not set
+# CONFIG_MTD_SPK300G_MAP_LARGE is not set
# CONFIG_MTD_PLATRAM is not set
#
diff --git a/cleopatre/buildroot/target/device/Spidcom/spk300g_defconfig b/cleopatre/buildroot/target/device/Spidcom/spk300g_defconfig
index af447fd266..72103681c0 100644
--- a/cleopatre/buildroot/target/device/Spidcom/spk300g_defconfig
+++ b/cleopatre/buildroot/target/device/Spidcom/spk300g_defconfig
@@ -68,6 +68,7 @@ BR2_TARGET_SPIDCOM=y
#
# Spidcom Specific Device Support
#
+# BR2_TARGET_SPIDCOM_ARIZONA is not set
BR2_TARGET_SPIDCOM_SPK300G=y
#
diff --git a/cleopatre/buildroot/target/linux/Makefile.in b/cleopatre/buildroot/target/linux/Makefile.in
index eb2b36ee11..ca6b352cf4 100644
--- a/cleopatre/buildroot/target/linux/Makefile.in
+++ b/cleopatre/buildroot/target/linux/Makefile.in
@@ -91,7 +91,7 @@ LINUX26_MAKE_FLAGS = HOSTCC="$(HOSTCC)" HOSTCFLAGS="$(HOSTCFLAGS)" \
INSTALL_MOD_PATH=$(TARGET_DIR) \
CROSS_COMPILE=$(KERNEL_CROSS) \
LDFLAGS="$(TARGET_LDFLAGS)" \
- LZMA="$(LZMA)"
+ LZMA="$(LZMA)"
$(LINUX26_KCONFIG):
@if [ ! -f "$(LINUX26_KCONFIG)" ] ; then \