summaryrefslogtreecommitdiff
path: root/cleopatre/buildroot/target
diff options
context:
space:
mode:
authorOlivier Dufour2013-01-14 10:03:33 +0100
committerOlivier Dufour2013-01-18 09:33:18 +0100
commit8251c53bf50579c44dbe323718d5da72b0516c2f (patch)
treed4f437ffe23ec3ec0320484b222e483eda4f0be8 /cleopatre/buildroot/target
parent5af56fa6d64209da97f4e6866b99195df43d37a7 (diff)
cleo/app/managerd: configure LED GPIO number, refs #3636
As MPR520 has more LED than previous boards, we can no longer rely on a single LED configuration for managerd.
Diffstat (limited to 'cleopatre/buildroot/target')
-rw-r--r--cleopatre/buildroot/target/device/Spidcom/response_file.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/cleopatre/buildroot/target/device/Spidcom/response_file.mk b/cleopatre/buildroot/target/device/Spidcom/response_file.mk
index 8690b0d175..cf4f55a709 100644
--- a/cleopatre/buildroot/target/device/Spidcom/response_file.mk
+++ b/cleopatre/buildroot/target/device/Spidcom/response_file.mk
@@ -43,6 +43,8 @@ FLAGS:=
# MSE500 specific
ifeq ($(BR2_TARGET_SPIDCOM_ARCH_MSE500),y)
FLAGS:=$(FLAGS) -DCONFIG_CHIP_FEATURE_EXTRA_NVRAM_FIELDS
+ FLAGS:=$(call conditional_define,$(BR2_TARGET_SPIDCOM_MPR520),CONFIG_HAVE_POWER_LED)
+ FLAGS:=$(call conditional_value,$(BR2_TARGET_SPIDCOM_MPR520),LED_ATTACHMENT_GPIO_NUM,4)
endif
# SPC300 specific