summaryrefslogtreecommitdiff
path: root/cleopatre/buildroot/target
diff options
context:
space:
mode:
authorOlivier Dufour2012-11-22 16:44:00 +0100
committerOlivier Dufour2012-11-29 17:55:18 +0100
commit0e8253d083770ee3e2234ffa0934f1227920751c (patch)
tree72fa358872d7f91b2aa4594681dc099ea3cdb1aa /cleopatre/buildroot/target
parentbb872de6d35155bfccdc6e82c5a972dd815cb940 (diff)
cleo/buildroot: add MSE500 in bundle generation, closes #3418
BR2_TARGET_SPIDCOM_BOARD allows generic board configuration. BR2_TARGET_SPIDCOM_CHIP allows to use chip specific binaries. It is now easier to add a new board, and support multiple chips.
Diffstat (limited to 'cleopatre/buildroot/target')
-rw-r--r--cleopatre/buildroot/target/device/Spidcom/Config.in44
-rw-r--r--cleopatre/buildroot/target/device/Spidcom/Makefile.in36
-rw-r--r--cleopatre/buildroot/target/device/Spidcom/arizona_defconfig6
-rw-r--r--cleopatre/buildroot/target/device/Spidcom/mse500_defconfig6
-rw-r--r--cleopatre/buildroot/target/device/Spidcom/mse500dini_300_defconfig6
-rw-r--r--cleopatre/buildroot/target/device/Spidcom/scr310_defconfig6
-rw-r--r--cleopatre/buildroot/target/device/Spidcom/spk300_defconfig6
-rw-r--r--cleopatre/buildroot/target/device/Spidcom/spk300g_defconfig6
-rw-r--r--cleopatre/buildroot/target/device/Spidcom/spk310_defconfig6
-rw-r--r--cleopatre/buildroot/target/device/Spidcom/spr300_defconfig6
-rw-r--r--cleopatre/buildroot/target/device/Spidcom/spr310_defconfig6
11 files changed, 90 insertions, 44 deletions
diff --git a/cleopatre/buildroot/target/device/Spidcom/Config.in b/cleopatre/buildroot/target/device/Spidcom/Config.in
index f16866f21e..7ba18bb8d3 100644
--- a/cleopatre/buildroot/target/device/Spidcom/Config.in
+++ b/cleopatre/buildroot/target/device/Spidcom/Config.in
@@ -13,54 +13,63 @@ choice
config BR2_TARGET_SPIDCOM_ARIZONA
bool "Arizona development board"
depends on BR2_arm
+ select BR2_TARGET_SPIDCOM_ARCH_SPC300
help
Support for the Arizona SPC300 based device
config BR2_TARGET_SPIDCOM_MSE500
bool "MSE500 development board"
depends on BR2_arm
+ select BR2_TARGET_SPIDCOM_ARCH_MSE500
help
Support for the MSE500 (300 mode)
config BR2_TARGET_SPIDCOM_MSE500DINI_300
bool "MSE500DINI_300 development board"
depends on BR2_arm
+ select BR2_TARGET_SPIDCOM_ARCH_MSE500
help
Support for the MSE500 DINI prototype (300 mode)
config BR2_TARGET_SPIDCOM_SPK300G
bool "SPK300-G development board"
depends on BR2_arm
+ select BR2_TARGET_SPIDCOM_ARCH_SPC300
help
Support for the SPK300-G SPC300 based device
config BR2_TARGET_SPIDCOM_SPK300
bool "SPK300 development board"
depends on BR2_arm
+ select BR2_TARGET_SPIDCOM_ARCH_SPC300
help
Support for the SPK300 SPC300 based device
config BR2_TARGET_SPIDCOM_SPK310
bool "SPK310 development board"
depends on BR2_arm
+ select BR2_TARGET_SPIDCOM_ARCH_SPC300
help
Support for the SPK310 SPC300 based device
config BR2_TARGET_SPIDCOM_SCR310
bool "SCR310 reference design board"
depends on BR2_arm
+ select BR2_TARGET_SPIDCOM_ARCH_SPC300
help
Support for the SCR310 SPC300 based device
config BR2_TARGET_SPIDCOM_SPR300
bool "SPR300 reference design board"
depends on BR2_arm
+ select BR2_TARGET_SPIDCOM_ARCH_SPC300
help
Support for the SPR300 SPC300 based device
config BR2_TARGET_SPIDCOM_SPR310
bool "SPR310 reference design board"
depends on BR2_arm
+ select BR2_TARGET_SPIDCOM_ARCH_SPC300
help
Support for the SPR310 SPC300 based device
@@ -72,4 +81,39 @@ config BR2_TARGET_SPIDCOM_PLC_MEM_SIZE_MB
help
Size of the memory dedicated to the PLC subsystem (in MB).
+config BR2_TARGET_SPIDCOM_ARCH_MSE500
+ def_bool n
+ help
+ Defines MSE500 chip family
+
+config BR2_TARGET_SPIDCOM_ARCH_SPC300
+ def_bool n
+ help
+ Defines SPC300 chip family
+
+config BR2_TARGET_SPIDCOM_BOARD
+ string
+ default "arizona" if BR2_TARGET_SPIDCOM_ARIZONA
+ default "mse500" if BR2_TARGET_SPIDCOM_MSE500
+ default "mse500dini_300" if BR2_TARGET_SPIDCOM_MSE500DINI_300
+ default "spk300g" if BR2_TARGET_SPIDCOM_SPK300G
+ default "spk300" if BR2_TARGET_SPIDCOM_SPK300
+ default "spk310" if BR2_TARGET_SPIDCOM_SPK310
+ default "scr310" if BR2_TARGET_SPIDCOM_SCR310
+ default "spr300" if BR2_TARGET_SPIDCOM_SPR300
+ default "spr310" if BR2_TARGET_SPIDCOM_SPR310
+ default "none"
+ depends on BR2_TARGET_SPIDCOM
+ help
+ Type of board
+
+config BR2_TARGET_SPIDCOM_CHIP
+ string
+ default "mse500" if BR2_TARGET_SPIDCOM_ARCH_MSE500
+ default "spc300" if BR2_TARGET_SPIDCOM_ARCH_SPC300
+ default "none"
+ depends on BR2_TARGET_SPIDCOM
+ help
+ Chip type of the board
+
endif
diff --git a/cleopatre/buildroot/target/device/Spidcom/Makefile.in b/cleopatre/buildroot/target/device/Spidcom/Makefile.in
index 9da28bdbe9..ab6170edc9 100644
--- a/cleopatre/buildroot/target/device/Spidcom/Makefile.in
+++ b/cleopatre/buildroot/target/device/Spidcom/Makefile.in
@@ -3,41 +3,7 @@ ifeq ($(strip $(BR2_TARGET_SPIDCOM)),y)
TARGET_SKELETON = target/device/Spidcom/target_skeleton
-ifeq ($(strip $(BR2_TARGET_SPIDCOM_ARIZONA)),y)
-include target/device/Spidcom/arizona/Makefile.in
-endif
-
-ifeq ($(strip $(BR2_TARGET_SPIDCOM_MSE500DINI_300)),y)
-include target/device/Spidcom/mse500dini_300/Makefile.in
-endif
-
-ifeq ($(strip $(BR2_TARGET_SPIDCOM_MSE500)),y)
-include target/device/Spidcom/mse500/Makefile.in
-endif
-
-ifeq ($(strip $(BR2_TARGET_SPIDCOM_SPK300G)),y)
-include target/device/Spidcom/spk300g/Makefile.in
-endif
-
-ifeq ($(strip $(BR2_TARGET_SPIDCOM_SPK300)),y)
-include target/device/Spidcom/spk300/Makefile.in
-endif
-
-ifeq ($(strip $(BR2_TARGET_SPIDCOM_SPK310)),y)
-include target/device/Spidcom/spk310/Makefile.in
-endif
-
-ifeq ($(strip $(BR2_TARGET_SPIDCOM_SCR310)),y)
-include target/device/Spidcom/scr310/Makefile.in
-endif
-
-ifeq ($(strip $(BR2_TARGET_SPIDCOM_SPR300)),y)
-include target/device/Spidcom/spr300/Makefile.in
-endif
-
-ifeq ($(strip $(BR2_TARGET_SPIDCOM_SPR310)),y)
-include target/device/Spidcom/spr310/Makefile.in
-endif
+include target/device/Spidcom/$(subst ",,$(BR2_TARGET_SPIDCOM_BOARD))/Makefile.in
BUNDLE_VERSION = tag-$(shell git describe --always 2>/dev/null)
LINUX_DOT_VERSION = $(shell cat $(LINUX_DIR)/.version 2>/dev/null || echo 0)
diff --git a/cleopatre/buildroot/target/device/Spidcom/arizona_defconfig b/cleopatre/buildroot/target/device/Spidcom/arizona_defconfig
index ad04ca5c0b..64ebab2739 100644
--- a/cleopatre/buildroot/target/device/Spidcom/arizona_defconfig
+++ b/cleopatre/buildroot/target/device/Spidcom/arizona_defconfig
@@ -1,6 +1,6 @@
#
# Automatically generated make config: don't edit
-# Fri Aug 17 16:24:59 2012
+# Tue Nov 20 16:52:52 2012
#
BR2_HAVE_DOT_CONFIG=y
BR2_VERSION="0.10.0-svn"
@@ -78,6 +78,10 @@ BR2_TARGET_SPIDCOM_ARIZONA=y
# BR2_TARGET_SPIDCOM_SPR300 is not set
# BR2_TARGET_SPIDCOM_SPR310 is not set
BR2_TARGET_SPIDCOM_PLC_MEM_SIZE_MB=4
+# BR2_TARGET_SPIDCOM_ARCH_MSE500 is not set
+BR2_TARGET_SPIDCOM_ARCH_SPC300=y
+BR2_TARGET_SPIDCOM_BOARD="arizona"
+BR2_TARGET_SPIDCOM_CHIP="spc300"
#
# Generic Architecture support
diff --git a/cleopatre/buildroot/target/device/Spidcom/mse500_defconfig b/cleopatre/buildroot/target/device/Spidcom/mse500_defconfig
index 46ee842dff..f6ba182c9a 100644
--- a/cleopatre/buildroot/target/device/Spidcom/mse500_defconfig
+++ b/cleopatre/buildroot/target/device/Spidcom/mse500_defconfig
@@ -1,6 +1,6 @@
#
# Automatically generated make config: don't edit
-# Wed Jun 20 13:57:45 2012
+# Tue Nov 20 16:52:53 2012
#
BR2_HAVE_DOT_CONFIG=y
BR2_VERSION="0.10.0-svn"
@@ -78,6 +78,10 @@ BR2_TARGET_SPIDCOM_MSE500=y
# BR2_TARGET_SPIDCOM_SPR300 is not set
# BR2_TARGET_SPIDCOM_SPR310 is not set
BR2_TARGET_SPIDCOM_PLC_MEM_SIZE_MB=4
+BR2_TARGET_SPIDCOM_ARCH_MSE500=y
+# BR2_TARGET_SPIDCOM_ARCH_SPC300 is not set
+BR2_TARGET_SPIDCOM_BOARD="mse500"
+BR2_TARGET_SPIDCOM_CHIP="mse500"
#
# Generic Architecture support
diff --git a/cleopatre/buildroot/target/device/Spidcom/mse500dini_300_defconfig b/cleopatre/buildroot/target/device/Spidcom/mse500dini_300_defconfig
index 12bd527c6d..51ee60dd17 100644
--- a/cleopatre/buildroot/target/device/Spidcom/mse500dini_300_defconfig
+++ b/cleopatre/buildroot/target/device/Spidcom/mse500dini_300_defconfig
@@ -1,6 +1,6 @@
#
# Automatically generated make config: don't edit
-# Fri Aug 17 16:25:21 2012
+# Tue Nov 20 16:52:54 2012
#
BR2_HAVE_DOT_CONFIG=y
BR2_VERSION="0.10.0-svn"
@@ -78,6 +78,10 @@ BR2_TARGET_SPIDCOM_MSE500DINI_300=y
# BR2_TARGET_SPIDCOM_SPR300 is not set
# BR2_TARGET_SPIDCOM_SPR310 is not set
BR2_TARGET_SPIDCOM_PLC_MEM_SIZE_MB=4
+BR2_TARGET_SPIDCOM_ARCH_MSE500=y
+# BR2_TARGET_SPIDCOM_ARCH_SPC300 is not set
+BR2_TARGET_SPIDCOM_BOARD="mse500dini_300"
+BR2_TARGET_SPIDCOM_CHIP="mse500"
#
# Generic Architecture support
diff --git a/cleopatre/buildroot/target/device/Spidcom/scr310_defconfig b/cleopatre/buildroot/target/device/Spidcom/scr310_defconfig
index eabd443850..a9d15c615d 100644
--- a/cleopatre/buildroot/target/device/Spidcom/scr310_defconfig
+++ b/cleopatre/buildroot/target/device/Spidcom/scr310_defconfig
@@ -1,6 +1,6 @@
#
# Automatically generated make config: don't edit
-# Fri Aug 17 16:25:10 2012
+# Tue Nov 20 16:52:55 2012
#
BR2_HAVE_DOT_CONFIG=y
BR2_VERSION="0.10.0-svn"
@@ -78,6 +78,10 @@ BR2_TARGET_SPIDCOM_SCR310=y
# BR2_TARGET_SPIDCOM_SPR300 is not set
# BR2_TARGET_SPIDCOM_SPR310 is not set
BR2_TARGET_SPIDCOM_PLC_MEM_SIZE_MB=4
+# BR2_TARGET_SPIDCOM_ARCH_MSE500 is not set
+BR2_TARGET_SPIDCOM_ARCH_SPC300=y
+BR2_TARGET_SPIDCOM_BOARD="scr310"
+BR2_TARGET_SPIDCOM_CHIP="spc300"
#
# Generic Architecture support
diff --git a/cleopatre/buildroot/target/device/Spidcom/spk300_defconfig b/cleopatre/buildroot/target/device/Spidcom/spk300_defconfig
index b6f277a5fa..d3004ecc57 100644
--- a/cleopatre/buildroot/target/device/Spidcom/spk300_defconfig
+++ b/cleopatre/buildroot/target/device/Spidcom/spk300_defconfig
@@ -1,6 +1,6 @@
#
# Automatically generated make config: don't edit
-# Fri Aug 17 16:25:31 2012
+# Tue Nov 20 16:52:56 2012
#
BR2_HAVE_DOT_CONFIG=y
BR2_VERSION="0.10.0-svn"
@@ -78,6 +78,10 @@ BR2_TARGET_SPIDCOM_SPK300=y
# BR2_TARGET_SPIDCOM_SPR300 is not set
# BR2_TARGET_SPIDCOM_SPR310 is not set
BR2_TARGET_SPIDCOM_PLC_MEM_SIZE_MB=4
+# BR2_TARGET_SPIDCOM_ARCH_MSE500 is not set
+BR2_TARGET_SPIDCOM_ARCH_SPC300=y
+BR2_TARGET_SPIDCOM_BOARD="spk300"
+BR2_TARGET_SPIDCOM_CHIP="spc300"
#
# Generic Architecture support
diff --git a/cleopatre/buildroot/target/device/Spidcom/spk300g_defconfig b/cleopatre/buildroot/target/device/Spidcom/spk300g_defconfig
index 54226fda53..b62119e5f0 100644
--- a/cleopatre/buildroot/target/device/Spidcom/spk300g_defconfig
+++ b/cleopatre/buildroot/target/device/Spidcom/spk300g_defconfig
@@ -1,6 +1,6 @@
#
# Automatically generated make config: don't edit
-# Fri Aug 17 16:25:42 2012
+# Tue Nov 20 16:52:57 2012
#
BR2_HAVE_DOT_CONFIG=y
BR2_VERSION="0.10.0-svn"
@@ -78,6 +78,10 @@ BR2_TARGET_SPIDCOM_SPK300G=y
# BR2_TARGET_SPIDCOM_SPR300 is not set
# BR2_TARGET_SPIDCOM_SPR310 is not set
BR2_TARGET_SPIDCOM_PLC_MEM_SIZE_MB=4
+# BR2_TARGET_SPIDCOM_ARCH_MSE500 is not set
+BR2_TARGET_SPIDCOM_ARCH_SPC300=y
+BR2_TARGET_SPIDCOM_BOARD="spk300g"
+BR2_TARGET_SPIDCOM_CHIP="spc300"
#
# Generic Architecture support
diff --git a/cleopatre/buildroot/target/device/Spidcom/spk310_defconfig b/cleopatre/buildroot/target/device/Spidcom/spk310_defconfig
index c95452e231..3c6470b753 100644
--- a/cleopatre/buildroot/target/device/Spidcom/spk310_defconfig
+++ b/cleopatre/buildroot/target/device/Spidcom/spk310_defconfig
@@ -1,6 +1,6 @@
#
# Automatically generated make config: don't edit
-# Fri Aug 17 16:25:52 2012
+# Tue Nov 20 16:52:58 2012
#
BR2_HAVE_DOT_CONFIG=y
BR2_VERSION="0.10.0-svn"
@@ -78,6 +78,10 @@ BR2_TARGET_SPIDCOM_SPK310=y
# BR2_TARGET_SPIDCOM_SPR300 is not set
# BR2_TARGET_SPIDCOM_SPR310 is not set
BR2_TARGET_SPIDCOM_PLC_MEM_SIZE_MB=4
+# BR2_TARGET_SPIDCOM_ARCH_MSE500 is not set
+BR2_TARGET_SPIDCOM_ARCH_SPC300=y
+BR2_TARGET_SPIDCOM_BOARD="spk310"
+BR2_TARGET_SPIDCOM_CHIP="spc300"
#
# Generic Architecture support
diff --git a/cleopatre/buildroot/target/device/Spidcom/spr300_defconfig b/cleopatre/buildroot/target/device/Spidcom/spr300_defconfig
index 8d9bba1c58..dd4cf4b2f7 100644
--- a/cleopatre/buildroot/target/device/Spidcom/spr300_defconfig
+++ b/cleopatre/buildroot/target/device/Spidcom/spr300_defconfig
@@ -1,6 +1,6 @@
#
# Automatically generated make config: don't edit
-# Fri Aug 17 16:26:03 2012
+# Tue Nov 20 16:52:59 2012
#
BR2_HAVE_DOT_CONFIG=y
BR2_VERSION="0.10.0-svn"
@@ -78,6 +78,10 @@ BR2_TARGET_SPIDCOM=y
BR2_TARGET_SPIDCOM_SPR300=y
# BR2_TARGET_SPIDCOM_SPR310 is not set
BR2_TARGET_SPIDCOM_PLC_MEM_SIZE_MB=4
+# BR2_TARGET_SPIDCOM_ARCH_MSE500 is not set
+BR2_TARGET_SPIDCOM_ARCH_SPC300=y
+BR2_TARGET_SPIDCOM_BOARD="spr300"
+BR2_TARGET_SPIDCOM_CHIP="spc300"
#
# Generic Architecture support
diff --git a/cleopatre/buildroot/target/device/Spidcom/spr310_defconfig b/cleopatre/buildroot/target/device/Spidcom/spr310_defconfig
index 25abae0783..2f6f3b5cc3 100644
--- a/cleopatre/buildroot/target/device/Spidcom/spr310_defconfig
+++ b/cleopatre/buildroot/target/device/Spidcom/spr310_defconfig
@@ -1,6 +1,6 @@
#
# Automatically generated make config: don't edit
-# Fri Aug 17 16:26:14 2012
+# Tue Nov 20 16:53:00 2012
#
BR2_HAVE_DOT_CONFIG=y
BR2_VERSION="0.10.0-svn"
@@ -78,6 +78,10 @@ BR2_TARGET_SPIDCOM=y
# BR2_TARGET_SPIDCOM_SPR300 is not set
BR2_TARGET_SPIDCOM_SPR310=y
BR2_TARGET_SPIDCOM_PLC_MEM_SIZE_MB=4
+# BR2_TARGET_SPIDCOM_ARCH_MSE500 is not set
+BR2_TARGET_SPIDCOM_ARCH_SPC300=y
+BR2_TARGET_SPIDCOM_BOARD="spr310"
+BR2_TARGET_SPIDCOM_CHIP="spc300"
#
# Generic Architecture support