summaryrefslogtreecommitdiff
path: root/cleopatre/buildroot/target/linux
diff options
context:
space:
mode:
authorsave2009-11-12 16:04:56 +0000
committersave2009-11-12 16:04:56 +0000
commit0d576ad2f7228aac409b961543d0a7dfbfc1fe59 (patch)
treedb49f2db7e302f429906479d79513f77a1427e8b /cleopatre/buildroot/target/linux
parent81844f1f10ed99aeae244d97c4aebd0548b40190 (diff)
cleo/buildroot: insert bundle version on linux kernel uname, closes #751
- the version is passed to linux through KBUILD_BUILD_VERSION make variable. This version number is calculated through git describe command. - For the bundle sources the version isn't calculated. git-svn-id: svn+ssh://pessac/svn/cesar/trunk@6378 017c9cb6-072f-447c-8318-d5b54f68fe89
Diffstat (limited to 'cleopatre/buildroot/target/linux')
-rw-r--r--cleopatre/buildroot/target/linux/Makefile.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/cleopatre/buildroot/target/linux/Makefile.in b/cleopatre/buildroot/target/linux/Makefile.in
index ca6b352cf4..e0447f8529 100644
--- a/cleopatre/buildroot/target/linux/Makefile.in
+++ b/cleopatre/buildroot/target/linux/Makefile.in
@@ -91,7 +91,8 @@ LINUX26_MAKE_FLAGS = HOSTCC="$(HOSTCC)" HOSTCFLAGS="$(HOSTCFLAGS)" \
INSTALL_MOD_PATH=$(TARGET_DIR) \
CROSS_COMPILE=$(KERNEL_CROSS) \
LDFLAGS="$(TARGET_LDFLAGS)" \
- LZMA="$(LZMA)"
+ LZMA="$(LZMA)" \
+ $(LINUX26_MAKE_EXTRA_FLAGS)
$(LINUX26_KCONFIG):
@if [ ! -f "$(LINUX26_KCONFIG)" ] ; then \