summaryrefslogtreecommitdiff
path: root/cleopatre/buildroot/package
diff options
context:
space:
mode:
authorThierry Carré2013-03-04 18:15:11 +0100
committerThierry Carré2013-03-08 14:22:54 +0100
commitace50e1d0887f92b41b61b03bdddd786de39a47a (patch)
treef32720005a2128ec779cbc75318540779b829224 /cleopatre/buildroot/package
parentd3e94268d0da53084401edc88721738da5de82c0 (diff)
cleo/{buildroot/package, app/spidapp}: update spidapp makefile rules
- use libspid-config script - add "-Wall" option - add libs dependencies, but don't compile them
Diffstat (limited to 'cleopatre/buildroot/package')
-rw-r--r--cleopatre/buildroot/package/spidapp/spidapp.mk11
1 files changed, 4 insertions, 7 deletions
diff --git a/cleopatre/buildroot/package/spidapp/spidapp.mk b/cleopatre/buildroot/package/spidapp/spidapp.mk
index 29b645068c..1ba644776b 100644
--- a/cleopatre/buildroot/package/spidapp/spidapp.mk
+++ b/cleopatre/buildroot/package/spidapp/spidapp.mk
@@ -39,12 +39,9 @@ $(SPIDAPP_DIR)/.configured: $(SPIDAPP_DIR)/.unpacked
touch $(SPIDAPP_DIR)/.configured
$(SPIDAPP_DIR)/spidapp: $(SPIDAPP_LIBSPID_SITE)/libspid.so \
- $(SPIDAPP_DIR)/.configured
+ $(SPIDAPP_DIR)/.configured FORCE_SPIDAPP_MAKE
$(TARGET_CONFIGURE_OPTS) \
- $(MAKE) -C $(SPIDAPP_DIR) spidapp \
- LINUX_DIR="$(BASE_DIR)/../linux-2.6.25.10-spc300" \
- LIBMME_DIR="$(BASE_DIR)/../application/libmme" \
- LIBSPID_DIR="$(SPIDAPP_LIBSPID_SITE)"
+ $(MAKE) -C $(SPIDAPP_DIR) spidapp
$(TARGET_DIR)/usr/bin/spidapp: $(SPIDAPP_DIR)/spidapp
mkdir -p $(TARGET_DIR)/usr/bin
@@ -59,8 +56,8 @@ spidapp-clean:
spidapp-dirclean:
rm -f $(SPIDAPP_DIR)
-# We declare $(SPIDAPP_DIR)/spidapp rule as PHONY to force compilation
-.PHONY: $(SPIDAPP_DIR)/spidapp
+# We declare FORCE_SPIDAPP_MAKE rule as PHONY to force compilation
+.PHONY: FORCE_SPIDAPP_MAKE
#############################################################
#