summaryrefslogtreecommitdiff
path: root/cleopatre/buildroot/package
diff options
context:
space:
mode:
authorOlivier Dufour2012-11-14 17:45:02 +0100
committerOlivier Dufour2012-12-21 15:15:45 +0100
commit8c10cce00c2d426af6b9a60bf12444e91c4ba7eb (patch)
treeb30f5c35261a06ebcef69f48bc36c94156250730 /cleopatre/buildroot/package
parenta87e735cbe7994e052c220f57d792b6c37a8c98d (diff)
cleo/app/pmd: add a daemon to handle power state changes, closes #2633
pmd polls /proc/pm/suspend_cmd, and triggers the suspend script when the criterias are matched. The criterias are defined and handled by the kernel, pmd only reads the status entry and triggers the script, as it cannot be done from kernel space.
Diffstat (limited to 'cleopatre/buildroot/package')
-rw-r--r--cleopatre/buildroot/package/Config.in1
-rw-r--r--cleopatre/buildroot/package/pmd/Config.in7
-rw-r--r--cleopatre/buildroot/package/pmd/pmd.mk76
3 files changed, 84 insertions, 0 deletions
diff --git a/cleopatre/buildroot/package/Config.in b/cleopatre/buildroot/package/Config.in
index cd3ea5e4cc..1c5eea8482 100644
--- a/cleopatre/buildroot/package/Config.in
+++ b/cleopatre/buildroot/package/Config.in
@@ -232,6 +232,7 @@ if BR2_TARGET_SPIDCOM
source "package/spidapp/Config.in"
source "package/plcd/Config.in"
source "package/plcdrv/Config.in"
+source "package/pmd/Config.in"
endif
source "package/portmap/Config.in"
source "package/pppd/Config.in"
diff --git a/cleopatre/buildroot/package/pmd/Config.in b/cleopatre/buildroot/package/pmd/Config.in
new file mode 100644
index 0000000000..c22dcc952a
--- /dev/null
+++ b/cleopatre/buildroot/package/pmd/Config.in
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_PMD
+ depends on BR2_TARGET_SPIDCOM_MSE500
+ bool "pmd"
+ help
+ Help program for power management deamon.
+
+ http://www.spidcom.com
diff --git a/cleopatre/buildroot/package/pmd/pmd.mk b/cleopatre/buildroot/package/pmd/pmd.mk
new file mode 100644
index 0000000000..a0cf1788e4
--- /dev/null
+++ b/cleopatre/buildroot/package/pmd/pmd.mk
@@ -0,0 +1,76 @@
+#############################################################
+#
+# pmd (Deamon to handle power management).
+#
+#############################################################
+# Copyright (C) 2012 by MStar
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU Library General Public License as
+# published by the Free Software Foundation; either version 2 of the
+# License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Library General Public License for more details.
+#
+# You should have received a copy of the GNU Library General Public
+# License along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+# USA
+#
+
+PMD_VERSION:=0.0.1
+PMD_SITE:=$(BASE_DIR)/../application/pmd
+PMD_NAME:=pmd-$(PMD_VERSION)
+PMD_DIR:=$(BUILD_DIR)/pmd-$(PMD_VERSION)
+
+pmd-source:
+
+$(PMD_DIR)/.unpacked:
+ ln -s $(PMD_SITE) $(PMD_DIR)
+ touch $(PMD_DIR)/.unpacked
+
+$(PMD_DIR)/.configured: $(PMD_DIR)/.unpacked
+ touch $(PMD_DIR)/.configured
+
+$(PMD_DIR)/pmd: $(PMD_DIR)/.configured
+ (cd $(PMD_DIR); $(TARGET_CONFIGURE_OPTS) $(MAKE))
+
+$(TARGET_DIR)/usr/bin/pmd: $(PMD_DIR)/pmd
+ mkdir -p $(TARGET_DIR)/usr/bin
+ cp $< $@
+
+$(TARGET_DIR)/usr/bin/suspend: $(PMD_DIR)/suspend
+ mkdir -p $(TARGET_DIR)/usr/bin
+ cp $< $@
+
+$(TARGET_DIR)/etc/init.d/S90pmd: $(PMD_DIR)/S90pmd
+ mkdir -p $(TARGET_DIR)/etc/init.d
+ cp $< $@
+
+pmd: uclibc $(TARGET_DIR)/usr/bin/pmd \
+ $(TARGET_DIR)/usr/bin/suspend \
+ $(TARGET_DIR)/etc/init.d/S90pmd \
+
+pmd-clean:
+ rm -f $(TARGET_DIR)/usr/bin/pmd
+ rm -f $(TARGET_DIR)/usr/bin/suspend
+ rm -f $(TARGET_DIR)/etc/init.d/S90pmd
+ -$(MAKE) -C $(PMD_DIR) clean
+
+pmd-dirclean:
+ rm -f $(PMD_DIR)
+
+# We declare $(PMD_DIR)/pmd rule as PHONY to force compilation
+.PHONY: $(PMD_DIR)/pmd
+
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(strip $(BR2_PACKAGE_PMD)),y)
+TARGETS+=pmd
+endif