summaryrefslogtreecommitdiff
path: root/cleopatre/buildroot/package/x11r7/xdriver_xf86-video-cyrix
diff options
context:
space:
mode:
authorlefranc2008-08-01 09:25:43 +0000
committerlefranc2008-08-01 09:25:43 +0000
commit9a2bcc0b92b392f1f21cd26927515e4d49bc128e (patch)
treed0bd193c764606c4c6e4b4568ef08d0ff3324b72 /cleopatre/buildroot/package/x11r7/xdriver_xf86-video-cyrix
parentd0cc0304ed6eaf72116743e13e5b3b3cbfd878bb (diff)
- import of buildroot original sources (20080729 version)
git-svn-id: svn+ssh://pessac/svn/cesar/trunk@2704 017c9cb6-072f-447c-8318-d5b54f68fe89
Diffstat (limited to 'cleopatre/buildroot/package/x11r7/xdriver_xf86-video-cyrix')
-rw-r--r--cleopatre/buildroot/package/x11r7/xdriver_xf86-video-cyrix/Config.in12
-rw-r--r--cleopatre/buildroot/package/x11r7/xdriver_xf86-video-cyrix/xdriver_xf86-video-cyrix-1.1.0-cross-compile.patch31
-rw-r--r--cleopatre/buildroot/package/x11r7/xdriver_xf86-video-cyrix/xdriver_xf86-video-cyrix.mk14
3 files changed, 57 insertions, 0 deletions
diff --git a/cleopatre/buildroot/package/x11r7/xdriver_xf86-video-cyrix/Config.in b/cleopatre/buildroot/package/x11r7/xdriver_xf86-video-cyrix/Config.in
new file mode 100644
index 0000000000..c473337aef
--- /dev/null
+++ b/cleopatre/buildroot/package/x11r7/xdriver_xf86-video-cyrix/Config.in
@@ -0,0 +1,12 @@
+config BR2_PACKAGE_XDRIVER_XF86_VIDEO_CYRIX
+ bool "xf86-video-cyrix"
+ select BR2_PACKAGE_XSERVER_XORG_SERVER
+ select BR2_PACKAGE_XPROTO_FONTSPROTO
+ select BR2_PACKAGE_XPROTO_RANDRPROTO
+ select BR2_PACKAGE_XPROTO_RENDERPROTO
+ select BR2_PACKAGE_XPROTO_XEXTPROTO
+ select BR2_PACKAGE_XPROTO_XF86DGAPROTO
+ select BR2_PACKAGE_XPROTO_XPROTO
+ help
+ xf86-video-cyrix 1.1.0
+ Cyrix video driver
diff --git a/cleopatre/buildroot/package/x11r7/xdriver_xf86-video-cyrix/xdriver_xf86-video-cyrix-1.1.0-cross-compile.patch b/cleopatre/buildroot/package/x11r7/xdriver_xf86-video-cyrix/xdriver_xf86-video-cyrix-1.1.0-cross-compile.patch
new file mode 100644
index 0000000000..09b3712736
--- /dev/null
+++ b/cleopatre/buildroot/package/x11r7/xdriver_xf86-video-cyrix/xdriver_xf86-video-cyrix-1.1.0-cross-compile.patch
@@ -0,0 +1,31 @@
+--- a/configure 2006-04-07 14:48:07.000000000 -0400
++++ b/configure 2008-06-23 11:09:35.000000000 -0400
+@@ -20264,28 +20264,8 @@ echo "$as_me: Building with package name
+ as_ac_File=`echo "ac_cv_file_$prefix/share/X11/sgml/defs.ent" | $as_tr_sh`
+ echo "$as_me:$LINENO: checking for $prefix/share/X11/sgml/defs.ent" >&5
+ echo $ECHO_N "checking for $prefix/share/X11/sgml/defs.ent... $ECHO_C" >&6
+-if eval "test \"\${$as_ac_File+set}\" = set"; then
+- echo $ECHO_N "(cached) $ECHO_C" >&6
+-else
+- test "$cross_compiling" = yes &&
+- { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
+-echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
+- { (exit 1); exit 1; }; }
+-if test -r "$prefix/share/X11/sgml/defs.ent"; then
+- eval "$as_ac_File=yes"
+-else
+- eval "$as_ac_File=no"
+-fi
+-fi
+-echo "$as_me:$LINENO: result: `eval echo '${'$as_ac_File'}'`" >&5
+-echo "${ECHO_T}`eval echo '${'$as_ac_File'}'`" >&6
+-if test `eval echo '${'$as_ac_File'}'` = yes; then
+- DEFS_ENT_PATH=$prefix/share/X11/sgml
+-else
+ DEFS_ENT_PATH=
+
+-fi
+-
+
+ # Extract the first word of "linuxdoc", so it can be a program name with args.
+ set dummy linuxdoc; ac_word=$2
diff --git a/cleopatre/buildroot/package/x11r7/xdriver_xf86-video-cyrix/xdriver_xf86-video-cyrix.mk b/cleopatre/buildroot/package/x11r7/xdriver_xf86-video-cyrix/xdriver_xf86-video-cyrix.mk
new file mode 100644
index 0000000000..2510d31221
--- /dev/null
+++ b/cleopatre/buildroot/package/x11r7/xdriver_xf86-video-cyrix/xdriver_xf86-video-cyrix.mk
@@ -0,0 +1,14 @@
+################################################################################
+#
+# xdriver_xf86-video-cyrix -- Cyrix video driver
+#
+################################################################################
+
+XDRIVER_XF86_VIDEO_CYRIX_VERSION = 1.1.0
+XDRIVER_XF86_VIDEO_CYRIX_SOURCE = xf86-video-cyrix-$(XDRIVER_XF86_VIDEO_CYRIX_VERSION).tar.bz2
+XDRIVER_XF86_VIDEO_CYRIX_SITE = http://xorg.freedesktop.org/releases/individual/driver
+XDRIVER_XF86_VIDEO_CYRIX_AUTORECONF = NO
+XDRIVER_XF86_VIDEO_CYRIX_DEPENDENCIES = xserver_xorg-server xproto_fontsproto xproto_randrproto xproto_renderproto xproto_xextproto xproto_xf86dgaproto xproto_xproto
+XDRIVER_XF86_VIDEO_CYRIX_INSTALL_TARGET_OPT = DESTDIR=$(TARGET_DIR) install
+
+$(eval $(call AUTOTARGETS,package/x11r7,xdriver_xf86-video-cyrix))