summaryrefslogtreecommitdiff
path: root/cleopatre/buildroot/Makefile
diff options
context:
space:
mode:
authorOlivier Dufour2012-11-20 09:58:37 +0100
committerOlivier Dufour2012-11-30 08:42:01 +0100
commit2ae58ed12a10ac1f02e7be4542911d01a1346a84 (patch)
tree3a2c886685dd7646608cdfc3d5c4ccc03b83c3f9 /cleopatre/buildroot/Makefile
parent0e8253d083770ee3e2234ffa0934f1227920751c (diff)
cleo/buildroot: add a Makefile to create response file, refs #3416
When invoking make xxx_defconfig, a response file containing all extra defines needed by applications to correctly use NVRAM is created.
Diffstat (limited to 'cleopatre/buildroot/Makefile')
-rw-r--r--cleopatre/buildroot/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/cleopatre/buildroot/Makefile b/cleopatre/buildroot/Makefile
index 866515147b..3418fe2e98 100644
--- a/cleopatre/buildroot/Makefile
+++ b/cleopatre/buildroot/Makefile
@@ -469,11 +469,15 @@ distclean: clean
endif # ifeq ($(BR2_HAVE_DOT_CONFIG),y)
+-include target/device/Spidcom/response_file.mk
+
%_defconfig: $(CONFIG)/conf
cp $(shell find ./target/ -name $@) .config
# If CCache tool exists, replace the BR2_TOOLCHAIN_EXTERNAL_PATH to use it.
if [ -e /opt/spidcom/spc300/ccache ]; then sed -i '/BR2_TOOLCHAIN_EXTERNAL_PATH=/s:spc300/usr:spc300/ccache:' .config; fi;
-@$(MAKE) oldconfig
+ # Generate response file
+ -@$(MAKE) response_file
update:
cp .config $(BOARD_PATH)/../$(BOARD_NAME)_defconfig