aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNicolas Schodet2021-10-02 22:16:42 +0200
committerNicolas Schodet2021-10-03 10:17:25 +0200
commit6c0730889b6a0a17139d245ad2d3b093af848d68 (patch)
tree70d5c0e9c42ef20dd6cc6ce258895f46b29bb347 /meson.build
parent0ebf261cb559560f1b7bee1fcd1113f3134c0ac1 (diff)
Update code to work with libusb 1.0
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 4 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index ce4f339..2687812 100644
--- a/meson.build
+++ b/meson.build
@@ -1,7 +1,7 @@
project('libnxt', 'c',
version : '0.3')
-usbdep = dependency('libusb', version : ['>=0.1', '<1.0'])
+usbdep = dependency('libusb-1.0')
subdir('flash_write')
@@ -20,15 +20,16 @@ lib = static_library('libnxt',
'lowlevel.c',
'samba.c',
flash_routine_h,
+ dependencies : usbdep,
)
executable('fwflash',
'main_fwflash.c',
- link_with : lib, dependencies : usbdep,
+ link_with : lib,
install : true,
)
executable('fwexec',
'main_fwexec.c',
- link_with : lib, dependencies : usbdep,
+ link_with : lib,
install : true,
)