summaryrefslogtreecommitdiff
path: root/AT91SAM7S256/armdebug/nxt-python-fantom/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'AT91SAM7S256/armdebug/nxt-python-fantom/setup.py')
-rw-r--r--AT91SAM7S256/armdebug/nxt-python-fantom/setup.py23
1 files changed, 23 insertions, 0 deletions
diff --git a/AT91SAM7S256/armdebug/nxt-python-fantom/setup.py b/AT91SAM7S256/armdebug/nxt-python-fantom/setup.py
new file mode 100644
index 0000000..9899347
--- /dev/null
+++ b/AT91SAM7S256/armdebug/nxt-python-fantom/setup.py
@@ -0,0 +1,23 @@
+#!/usr/bin/env python
+
+from distutils.core import setup
+
+try:
+ readme = open('README', 'r')
+ ldesc = readme.read(8192)
+ readme.close()
+except:
+ ldesc = ""
+
+setup(
+ name='nxt-python',
+ version='2.1.0',
+ author='Marcus Wanner',
+ author_email='marcusw@cox.net',
+ description='LEGO Mindstorms NXT Control Package',
+ url='http://code.google.com/p/nxt-python/',
+ license='Gnu GPL v3',
+ packages=['nxt', 'nxt.sensor'],
+ scripts=['scripts/nxt_push', 'scripts/nxt_test', 'scripts/nxt_filer'],
+ long_description=ldesc
+)