summaryrefslogtreecommitdiff
path: root/FantomModule/setup.py
diff options
context:
space:
mode:
authorTat-Chee Wan (USM)2011-03-01 15:49:21 +0800
committerTat-Chee Wan (USM)2011-03-01 15:49:21 +0800
commitedf4a348de0ddaf3bd0429d3cbb7dacc3b748954 (patch)
treec6db70e27f2d14c9c2615af5fd9d03752108aede /FantomModule/setup.py
parenta9c9b62a94e0398e5be0f3eb5f1ef666548617ca (diff)
added pyfantom python module, renamed .cp to .cpp, add setup.py
Diffstat (limited to 'FantomModule/setup.py')
-rw-r--r--FantomModule/setup.py35
1 files changed, 35 insertions, 0 deletions
diff --git a/FantomModule/setup.py b/FantomModule/setup.py
new file mode 100644
index 0000000..25dd152
--- /dev/null
+++ b/FantomModule/setup.py
@@ -0,0 +1,35 @@
+from distutils.core import setup, Extension
+import sys
+
+def getextensions():
+ mac_ext = Extension("FantomModule",
+ define_macros=[('PYFANTOM_DEBUG', '0')], # set to '1' to print debug messges
+ include_dirs=['.'],
+ extra_compile_args=['-arch i386'],
+ libraries=["Fantom"],
+ sources=["FantomModule.cpp"]
+ )
+ return [mac_ext]
+
+# install the main library
+setup(name="pyfantom",
+ version="0.1",
+ author="Tat-Chee Wan",
+ author_email="tcwan@cs.usm.my",
+ url="",
+ description="Python Extension to call Fantom Driver",
+ long_description="Python Wrapper for Fantom Driver on Mac OS X.",
+ license="GPL",
+ packages=["pyfantom"],
+ ext_modules=getextensions(),
+ classifiers = [ "Development Status :: 3 - Alpha",
+ "Intended Audience :: Developers",
+ # Need to confirm Fantom / NI-VISA license compatibility
+ # "License :: OSI Approved :: GNU General Public License (GPL)",
+ # "License :: OSI Approved :: GNU General Public License v2",
+ "Programming Language :: C++",
+ "Topic :: Software Development :: Libraries",
+ "Topic :: System :: Networking",
+ "Topic :: Communications",
+ "Operating System :: MacOS :: MacOS X" ]
+ )