aboutsummaryrefslogtreecommitdiffhomepage
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py22
1 files changed, 22 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..3275843
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,22 @@
+#!/usr/bin/env python
+
+from distutils.core import setup
+
+try:
+ readme = open('README', 'r')
+ ldesc = readme.read(8192)
+ readme.close()
+except:
+ ldesc = ""
+
+setup(
+ name='pyfantom',
+ version='0.1',
+ author='Nicolas Schodet',
+ author_email='nico at ni.fr.eu.org',
+ description='Python Wrapper for LEGO Mindstorms NXT Fantom Driver',
+ url='http://git.ni.fr.eu.org/?p=pyfantom.git;a=summary',
+ license='Gnu GPL v2',
+ py_modules=['pyfantom'],
+ long_description=ldesc
+)