aboutsummaryrefslogtreecommitdiffhomepage
path: root/setup.py
diff options
context:
space:
mode:
authorTat-Chee Wan (USM)2011-06-03 15:34:22 +0800
committerNicolas Schodet2012-02-08 22:21:04 +0100
commit0cb7812c2b8b42df9b48f1d8537b16386ac1db92 (patch)
tree8a703cbf2229155201f47f48863cb8ecb56c41f9 /setup.py
parent5aade3e1f58f8ea527f75682b56692383c864c77 (diff)
added setup information for package release
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py22
1 files changed, 22 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..3275843
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,22 @@
+#!/usr/bin/env python
+
+from distutils.core import setup
+
+try:
+ readme = open('README', 'r')
+ ldesc = readme.read(8192)
+ readme.close()
+except:
+ ldesc = ""
+
+setup(
+ name='pyfantom',
+ version='0.1',
+ author='Nicolas Schodet',
+ author_email='nico at ni.fr.eu.org',
+ description='Python Wrapper for LEGO Mindstorms NXT Fantom Driver',
+ url='http://git.ni.fr.eu.org/?p=pyfantom.git;a=summary',
+ license='Gnu GPL v2',
+ py_modules=['pyfantom'],
+ long_description=ldesc
+)