summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog25
1 files changed, 23 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index c263fc96..c74cd929 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,5 +1,26 @@
-propellor (5.8.1) UNRELEASED; urgency=medium
-
+propellor (5.9.0) UNRELEASED; urgency=medium
+
+ * Avoid displaying an excessive amount of type error messages when many
+ properties have been combined in a props list.
+ * Added custom type error messages when Properties don't combine due to
+ conflicting MetaTypes.
+ * Added custom type error messages for ensureProperty and tightenTargets.
+ * Note that those changes made ghc 8.0.1 in a few cases unable to infer
+ types when ensureProperty or tightenTargets is used. Adding a type
+ annotation will work around this problem, if you cannot upgrade
+ to a newer ghc that handles them better.
+ * Use the type-errors library to detect when the type checker gets stuck
+ unable to reduce type-level operations on MetaTypes, and avoid
+ displaying massive error messages in such a case.
+ * But, since type-errors is a new library not available in eg Debian
+ yet, added a WithTypeErrors build flag. When the library is not
+ available, cabal will automatically disable that build flag,
+ and it will build without the type-errors library.
+ * ensureProperty: The constraints have been simplified
+ to EnsurePropertyAllowed. (API change)
+ * ensureProperty: The contraints have been simplified
+ to TightenTargetsAllowed. (API change)
+ * CheckCombinable generates a Bool. (API change)
* Libvirt.installed: install libvirt-daemon-system
Thanks, David Bremner