summaryrefslogtreecommitdiff
path: root/debian/changelog
diff options
context:
space:
mode:
Diffstat (limited to 'debian/changelog')
-rw-r--r--debian/changelog18
1 files changed, 14 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index ba94f6bf..6b3f6940 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,14 +1,24 @@
propellor (2.13.0) UNRELEASED; urgency=medium
- * Added Propellor.Property.Concurrent for concurrent properties.
- (Note that no output multiplexing is currently done.)
+ * RevertableProperty used to be assumed to contain info, but this is
+ now made explicit, with RevertableProperty HasInfo or
+ RevertableProperty NoInfo. (API change)
+ Transition guide:
+ - If you define a RevertableProperty, expect some type check
+ failures like: "Expecting one more argument to ‘RevertableProperty’".
+ - Change it to "RevertableProperty NoInfo"
+ - The compiler will then tell you if it needs "HasInfo" instead.
+ - If you have code that uses the RevertableProperty constructor
+ that fails to type check, use the more powerful <!> operator
+ instead to create the RevertableProperty.
* Various property combinators that combined a RevertableProperty
with a non-revertable property used to yield a RevertableProperty.
This was a bug, because the combined property could not be fully
- reverted in many cases. Fixed by making the combined property
- instead be a Property HasInfo.
+ reverted in many cases, and the result is now a non-revertable property.
* combineWith now takes an additional parameter to control how revert
actions are combined (API change).
+ * Added Propellor.Property.Concurrent for concurrent properties.
+ (Note that no output multiplexing is currently done.)
* Add File.isCopyOf. Thanks, Per Olofsson.
-- Joey Hess <id@joeyh.name> Sat, 24 Oct 2015 15:16:45 -0400