summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJoey Hess2015-10-28 14:46:17 -0400
committerJoey Hess2015-10-28 14:46:17 -0400
commit111ea88d4d7c54e9ab7950962ad22528d54dd959 (patch)
tree69053673ab24be9eb61f0ce87c23d2d84b108ae7 /debian
parent68dbfe1b08c9cf1d976ac84ea53817c54fcd3479 (diff)
fix bad MVar use, use STM
I had 2 MVars both involved in the same lock, and it seemed intractable to avoid deadlocks with them. STM makes it easy. At this point, the concurrent process stuff seems to work pretty well, but I'm not 100% sure it's not got some bugs.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog1
-rw-r--r--debian/control2
2 files changed, 3 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 6c154e1a..f3522b7c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -19,6 +19,7 @@ propellor (2.13.0) UNRELEASED; urgency=medium
actions are combined (API change).
* Added Propellor.Property.Concurrent for concurrent properties.
* execProcess and everything built on it is now concurrent output safe.
+ * Propellor now depends on stm.
* Add File.isCopyOf. Thanks, Per Olofsson.
-- Joey Hess <id@joeyh.name> Sat, 24 Oct 2015 15:16:45 -0400
diff --git a/debian/control b/debian/control
index 7f42c916..2956fdaa 100644
--- a/debian/control
+++ b/debian/control
@@ -17,6 +17,7 @@ Build-Depends:
libghc-mtl-dev,
libghc-transformers-dev,
libghc-exceptions-dev (>= 0.6),
+ libghc-stm-dev,
Maintainer: Gergely Nagy <algernon@madhouse-project.org>
Standards-Version: 3.9.6
Vcs-Git: git://git.joeyh.name/propellor
@@ -39,6 +40,7 @@ Depends: ${misc:Depends}, ${shlibs:Depends},
libghc-mtl-dev,
libghc-transformers-dev,
libghc-exceptions-dev (>= 0.6),
+ libghc-stm-dev,
git,
make,
Description: property-based host configuration management in haskell