summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJoey Hess2015-11-01 11:30:36 -0400
committerJoey Hess2015-11-01 11:30:36 -0400
commit046d7d82b4b309ade5e3508817f1b9b684e57b94 (patch)
treeb1e6cc3f2d959c7726e3da0c67551927d6a321c8 /debian
parent082bfc9f301adc59d7cd26954d8cdc0caf80ec7e (diff)
parentb218820da0b069e826507150cba118f0fa69d409 (diff)
Merge branch 'joeyconfig'
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog23
-rw-r--r--debian/control6
2 files changed, 24 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index c5eef2c9..a1abbc79 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,14 +1,29 @@
propellor (2.13.0) UNRELEASED; urgency=medium
- * Added Propellor.Property.Concurrent for concurrent properties.
- (Note that no output multiplexing is currently done.)
+ * RevertableProperty used to be assumed to contain info, but this is
+ now made explicit, with RevertableProperty HasInfo or
+ RevertableProperty NoInfo. (API change)
+ Transition guide:
+ - If you define a RevertableProperty, expect some type check
+ failures like: "Expecting one more argument to ‘RevertableProperty’".
+ - Change it to "RevertableProperty NoInfo"
+ - The compiler will then tell you if it needs "HasInfo" instead.
+ - If you have code that uses the RevertableProperty constructor
+ that fails to type check, use the more powerful <!> operator
+ instead to create the RevertableProperty.
* Various property combinators that combined a RevertableProperty
with a non-revertable property used to yield a RevertableProperty.
This was a bug, because the combined property could not be fully
- reverted in many cases. Fixed by making the combined property
- instead be a Property HasInfo.
+ reverted in many cases, and the result is now a non-revertable property.
* combineWith now takes an additional parameter to control how revert
actions are combined (API change).
+ * Added Propellor.Property.Concurrent for concurrent properties.
+ * Made the execProcess exported by propellor, and everything built on it,
+ avoid scrambled output when run concurrently.
+ * Propellor now depends on STM and text.
+ * The cabal file now builds propellor with -O. While -O0 makes ghc
+ take less memory while building propellor, it can lead to bad memory
+ usage at runtime due to eg, disabled stream fusion.
* Add File.isCopyOf. Thanks, Per Olofsson.
-- Joey Hess <id@joeyh.name> Sat, 24 Oct 2015 15:16:45 -0400
diff --git a/debian/control b/debian/control
index 7f42c916..1a7909a3 100644
--- a/debian/control
+++ b/debian/control
@@ -17,7 +17,9 @@ Build-Depends:
libghc-mtl-dev,
libghc-transformers-dev,
libghc-exceptions-dev (>= 0.6),
-Maintainer: Gergely Nagy <algernon@madhouse-project.org>
+ libghc-stm-dev,
+ libghc-text-dev,
+Maintainer: Joey Hess <id@joeyh.name>
Standards-Version: 3.9.6
Vcs-Git: git://git.joeyh.name/propellor
Homepage: http://propellor.branchable.com/
@@ -39,6 +41,8 @@ Depends: ${misc:Depends}, ${shlibs:Depends},
libghc-mtl-dev,
libghc-transformers-dev,
libghc-exceptions-dev (>= 0.6),
+ libghc-stm-dev,
+ libghc-text-dev,
git,
make,
Description: property-based host configuration management in haskell