summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJoey Hess2016-03-26 13:50:38 -0400
committerJoey Hess2016-03-26 13:50:38 -0400
commit2962f5c783db7a0f7014a8745768948c15d6a8ea (patch)
tree55c75394ef0760ef0e9e89d7437f13daee394a41 /debian
parent57adcf0e445ae31cf9a9db66d3a7f4793c8399a6 (diff)
fixed type checking of Ssh
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog12
1 files changed, 12 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index b27559bd..1bbc1f0e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -25,6 +25,18 @@ propellor (3.0.0) UNRELEASED; urgency=medium
"Property Debian"
- It's also possible make a property support a set of OS's, for example:
"Property (Debian + FreeBSD)"
+ - Removed `infoProperty` and `simpleProperty` constructors, instead use
+ `property` to construct a Property.
+ - Due to the polymorphic type returned by `property`, additional type
+ signatures tend to be needed when using it. For example, this will
+ fail to type check, because the type checker cannot guess what type
+ you intend the intermediate property "go" to have:
+ foo :: Property UnixLike
+ foo = go `requires` bar
+ where
+ go = property "foo" (return NoChange)
+ To fix, specify the type of go:
+ go :: Property UnixLike
- `ensureProperty` now needs to be passed information about the
property it's used in.
change this: foo = property desc $ ... ensureProperty bar