summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJoey Hess2016-03-27 18:32:01 -0400
committerJoey Hess2016-03-27 18:32:01 -0400
commit500635568514bc106597a857c60d268dcf668037 (patch)
tree8c8b036b6526e83f88a0b83944e30c128ccad8e1 /debian
parent7e76731a0098a6cd47979c86c8a484cc47e0b0d7 (diff)
split out singletons lib
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog4
1 files changed, 2 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index fc499c86..af2f5c2b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -39,10 +39,10 @@ propellor (3.0.0) UNRELEASED; urgency=medium
go = property "foo" (return NoChange)
To fix, specify the type of go:
go :: Property UnixLike
- - `ensureProperty` now needs to be passed information about the
+ - `ensureProperty` now needs to be passed a witness to the type of the
property it's used in.
change this: foo = property desc $ ... ensureProperty bar
- to this: foo = property' desc $ \o -> ... ensureProperty o bar
+ to this: foo = property' desc $ \w -> ... ensureProperty w bar
- General purpose properties like cmdProperty have type "Property UnixLike".
When using that to run a command only available on Debian, you can
tighten the type to only the OS that your more specific property works on.