summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJoey Hess2017-07-12 19:12:36 -0400
committerJoey Hess2017-07-12 19:12:36 -0400
commit08010583fa42af1b2b5ab070e4742263d43b26cf (patch)
tree6a65363f435863139950616cc12ca7ef74042fdf /debian
parent8e172612f5675a9dab4c302e9353af7e77773d45 (diff)
add bootstrapWith property to support stack and more
* Hosts can be configured to build propellor using stack, by adding a property: & bootstrapWith (Robustly Stack) * Hosts can be configured to build propellor using cabal, but using only packages installed from the operating system. This will work on eg Debian: & bootstrapWith OSOnly propellor build its config using stack. (This does not affect how propellor is bootstrapped on a host by "propellor --spin host".) This has not yet been tested at all! But should probably work fine. This is based on earlier work by Arnaud Bailly, who made Propellor.Bootstrap use stack without parameterization. In Arnaud's patch, stack was installed using wget, but that only worked on linux-x86_64 and was insecure. I instead chose to use the distribution packages of stack, like is done for cabal. Debian stack has haskell-stack now, and it's getting into many distributions. This commit was sponsored by Francois Marier on Patreon.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog10
1 files changed, 9 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 24552b21..be0285f9 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,13 @@ propellor (4.3.1) UNRELEASED; urgency=medium
* Added Propellor.Property.FreeDesktop module.
* Added reservedSpacePercentage to the PartSpec EDSL.
+ * Hosts can be configured to build propellor using stack, by adding
+ a property:
+ & bootstrapWith (Robustly Stack)
+ * Hosts can be configured to build propellor using cabal, but using
+ only packages installed from the operating system. This
+ will work on eg Debian:
+ & bootstrapWith OSOnly
-- Joey Hess <id@joeyh.name> Wed, 05 Jul 2017 22:57:42 -0400
@@ -473,7 +480,8 @@ propellor (3.0.0) unstable; urgency=medium
a clone of propellor's git repository, or a minimal config, and will
configure propellor to use a gpg key.
* Stack support. "git config propellor.buildsystem stack" will make
- propellor build its config using stack.
+ propellor build its config using stack. (This does not affect
+ how propellor is bootstrapped on a host by "propellor --spin host".)
* When propellor is installed using stack, propellor --init will
automatically set propellor.buildsystem=stack.