summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJoey Hess2015-01-24 22:38:10 -0400
committerJoey Hess2015-01-24 22:38:51 -0400
commit0ee04ecc43e047b00437fb660e71f7dd67dd3afc (patch)
tree621e0ebc68a2afb9410ce6f368bec865f31cc507 /debian
parent141a7c028bba8d5b9743f2ab1397e69c313a523c (diff)
GADT properties seem to work (untested)
* Property has been converted to a GADT, and will be Property NoInfo or Property HasInfo. This was done to make sure that ensureProperty is only used on properties that do not have Info. Transition guide: - Change all "Property" to "Property NoInfo" or "Property WithInfo" (The compiler can tell you if you got it wrong!) - To construct a RevertableProperty, it is useful to use the new (<!>) operator - Constructing a list of properties can be problimatic, since Property NoInto and Property WithInfo are different types and cannot appear in the same list. To deal with this, "props" has been added, and can built up a list of properties of different types, using the same (&) and (!) operators that are used to build up a host's properties.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog20
1 files changed, 17 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 3d3e9e07..abf6bd16 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,9 +1,23 @@
-propellor (1.4.0) UNRELEASED; urgency=medium
-
+propellor (2.0.0) UNRELEASED; urgency=medium
+
+ * Property has been converted to a GADT, and will be Property NoInfo
+ or Property HasInfo.
+ This was done to make sure that ensureProperty is only used on
+ properties that do not have Info.
+ Transition guide:
+ - Change all "Property" to "Property NoInfo" or "Property WithInfo"
+ (The compiler can tell you if you got it wrong!)
+ - To construct a RevertableProperty, it is useful to use the new
+ (<!>) operator
+ - Constructing a list of properties can be problimatic, since
+ Property NoInto and Property WithInfo are different types and cannot
+ appear in the same list. To deal with this, "props" has been added,
+ and can built up a list of properties of different types,
+ using the same (&) and (!) operators that are used to build
+ up a host's properties.
* Add descriptions of how to set missing fields to --list-fields output.
* Properties now form a tree, instead of the flat list used before.
This includes the properties used inside a container.
- (API change)
* Fix info propigation from fallback combinator's second Property.
* Added systemd configuration properties.
* Added journald configuration properties.