summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJoey Hess2015-12-05 17:53:32 -0400
committerJoey Hess2015-12-05 17:53:32 -0400
commit97a224b194b96184c7938de0bb1e1f423612ccbc (patch)
tree7cc147c4726af8644510c07ba87597920f8301dc /debian
parent5c6a43c3b888242443d790efbc1f9282e4e5675c (diff)
parent12548bae3d8feecce6a322162d91b827289ae824 (diff)
Merge branch 'joeyconfig'
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog21
1 files changed, 18 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index e7afe17d..1da30f22 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,11 +1,26 @@
-propellor (2.14.1) UNRELEASED; urgency=medium
-
+propellor (2.15.0) UNRELEASED; urgency=medium
+
+ * Added UncheckedProperty type, along with unchecked to indicate a
+ Property needs its result checked, and checkResult and changesFile
+ to check for changes.
+ * Properties that run an arbitrary command, such as cmdProperty
+ and scriptProperty are converted to use UncheckedProperty, since
+ they cannot tell on their own if the command truely made a change or not.
+ (API Change)
+ Transition guide:
+ - When GHC complains about an UncheckedProperty, add:
+ `assume` MadeChange
+ - Since these properties used to always return MadeChange, that
+ change is always safe to make.
+ - Or, if you know that the command should modifiy a file, use:
+ `changesFile` filename
+ * A few properties have had their Result improved, for example
+ Apt.buldDep and Apt.autoRemove now check if a change was made or not.
* User.hasDesktopGroups changed to avoid trying to add the user to
groups that don't exist.
* Added Postfix.saslPasswdSet.
* Added Propellor.Property.Locale.
Thanks, Sean Whitton.
- * Added changesFile property combinator.
* Added Propellor.Property.Fail2Ban.
-- Joey Hess <id@joeyh.name> Tue, 24 Nov 2015 17:06:12 -0400