summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJoey Hess2017-03-15 15:36:29 -0400
committerJoey Hess2017-03-15 15:39:18 -0400
commit472759eef32534fd1f1e14bb05f5cb97b18de760 (patch)
tree062b3e66071660571d32256b4882d1ed3127a54e /debian
parent52ca81661f156122a3a5d4a438fea83e067215ac (diff)
Added Monoid instances for Property and RevertableProperty.
* Added Monoid instances for Property and RevertableProperty. * Removed applyToList. Instead, use mconcat. (API change) Eg, if you had: applyToList accountFor [User "joey", User "root"] use instead: mconcat (map accountFor [User "joey", User "root"]) mappend x y is basically the same as x `before` y. In particular, if x fails to be ensured, it won't ensure y. This seems to make sense, since applyToList had that behavior, and so does the Monoid for Propellor Result. The alternative would be to try to ensure both and combine the results. However, I don't see any reason to do it that way. It would be nice if the description of both properties were displayed when ensuring the combination. But then, it would need to display eg: ensuring x..ok ensuring y..failed ensuring x and ensuring y..failed Without a way to get rid of that redundant last line, I don't want to do that. Note that the haddocks for the Monoid instances need a really wide screen to display! This is IMHO an infelicity in haddock, and I can't do anything about it really. This commit was sponsored by Fernando Jimenez on Patreon.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog4
1 files changed, 4 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 460d468d..9168b5f9 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -24,6 +24,10 @@ propellor (3.5.0) UNRELEASED; urgency=medium
* When Nothing needs to be done to ensure a property, propellor
will avoid displaying its description at all. The doNothing property
is an example of such a property.
+ * Added Monoid instances for Property and RevertableProperty.
+ * Removed applyToList. Instead, use mconcat. (API change)
+ Eg, if you had: applyToList accountFor [User "joey", User "root"]
+ use instead: mconcat (map accountFor [User "joey", User "root"])
-- Joey Hess <id@joeyh.name> Wed, 08 Mar 2017 14:02:10 -0400