summaryrefslogtreecommitdiff
path: root/cleopatre/buildroot/package
diff options
context:
space:
mode:
Diffstat (limited to 'cleopatre/buildroot/package')
-rw-r--r--cleopatre/buildroot/package/lltd/lltd.mk7
1 files changed, 4 insertions, 3 deletions
diff --git a/cleopatre/buildroot/package/lltd/lltd.mk b/cleopatre/buildroot/package/lltd/lltd.mk
index 6b7d31a0b7..836b414cbf 100644
--- a/cleopatre/buildroot/package/lltd/lltd.mk
+++ b/cleopatre/buildroot/package/lltd/lltd.mk
@@ -36,7 +36,8 @@ $(LLTD_DIR)/.unpacked:
$(LLTD_DIR)/.configured: $(LLTD_DIR)/.unpacked
touch $(LLTD_DIR)/.configured
-$(LLTD_DIR)/lltd: $(LLTD_DIR)/.configured
+$(LLTD_DIR)/lltd: $(LLTD_DIR)/.configured \
+ FORCE_LLTD_MAKE
$(TARGET_CONFIGURE_OPTS) \
$(MAKE) -C $(LLTD_DIR) lltd
@@ -52,8 +53,8 @@ lltd-clean:
lltd-dirclean:
rm -f $(LLTD_DIR)
-# We declare $(LLTD_DIR)/lltd rule as PHONY to force compilation
-.PHONY: $(LLTD_DIR)/lltd
+# We declare FORCE_LLTD_MAKE rule as PHONY to force compilation
+.PHONY: FORCE_LLTD_MAKE
#############################################################
#