summaryrefslogtreecommitdiff
path: root/cleopatre/buildroot/package/afe/afe.mk
diff options
context:
space:
mode:
Diffstat (limited to 'cleopatre/buildroot/package/afe/afe.mk')
-rw-r--r--cleopatre/buildroot/package/afe/afe.mk64
1 files changed, 64 insertions, 0 deletions
diff --git a/cleopatre/buildroot/package/afe/afe.mk b/cleopatre/buildroot/package/afe/afe.mk
new file mode 100644
index 0000000000..3f87025ee4
--- /dev/null
+++ b/cleopatre/buildroot/package/afe/afe.mk
@@ -0,0 +1,64 @@
+#############################################################
+#
+# afe (provides Analog Front End configuration application)
+# (works only under SPiDCOM SPC300 board)
+#
+#############################################################
+# Copyright (C) 2009 by SPiDCOM technologies
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU Library General Public License as
+# published by the Free Software Foundation; either version 2 of the
+# License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Library General Public License for more details.
+#
+# You should have received a copy of the GNU Library General Public
+# License along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+# USA
+#
+
+AFE_VERSION:=0.0.1
+AFE_SITE:=$(BASE_DIR)/../application/afe
+AFE_NAME:=afe-$(AFE_VERSION)
+AFE_DIR:=$(BUILD_DIR)/afe-$(AFE_VERSION)
+
+afe-source:
+
+$(AFE_DIR)/.unpacked:
+ @echo "UNPACKED"
+ ln -s $(AFE_SITE) $(AFE_DIR)
+ touch $(AFE_DIR)/.unpacked
+
+$(AFE_DIR)/.configured: $(AFE_DIR)/.unpacked
+ @echo "CONFIGURED"
+ touch $(AFE_DIR)/.configured
+
+$(AFE_DIR)/afe: $(AFE_DIR)/.configured
+ @echo "AFE"
+ (cd $(AFE_DIR); $(TARGET_CONFIGURE_OPTS) $(MAKE) LINUX_DIR="$(BASE_DIR)/../linux-2.6.25.10-spc300")
+
+$(TARGET_DIR)/usr/bin/afe: $(AFE_DIR)/afe
+ @echo "ROOTFS AFE"
+ cp $(AFE_DIR)/afe $(TARGET_DIR)/usr/bin/afe
+
+afe: uclibc $(TARGET_DIR)/usr/bin/afe
+
+afe-clean:
+ rm -f $(TARGET_DIR)/usr/bin/afe
+ -$(MAKE) -C $(AFE_DIR) clean
+
+afe-dirclean:
+ rm -f $(AFE_DIR)
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(strip $(BR2_PACKAGE_AFE)),y)
+TARGETS+=afe
+endif