summaryrefslogtreecommitdiff
path: root/i/simulotron/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'i/simulotron/src/Makefile.am')
-rw-r--r--i/simulotron/src/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/i/simulotron/src/Makefile.am b/i/simulotron/src/Makefile.am
index 7302a68..3a767e2 100644
--- a/i/simulotron/src/Makefile.am
+++ b/i/simulotron/src/Makefile.am
@@ -1,9 +1,14 @@
+SUBDIRS = utils socket
+
bin_PROGRAMS = simulotron
simulotron_SOURCES = main.cc \
- socket/socket.cc socket/socket.hh \
- socket/address.cc socket/address.hh \
+ socket/address.hh socket/address.cc \
+ socket/socket.cc socket/socket.hh \
utils/errno_exception.hh
simulotron_CXXFLAGS = -g -Wall -fmessage-length=0
simulotron_LDADD =
INCLUDES = -I../../src
+
+TESTS = socket/test_socket \
+ utils/test_errno_exception